Fix for file injection is broken on centos computes with Cirros images LP #1587960 73/21573/2 master
authorAlbert <asyriy@mirantis.com>
Thu, 2 Jun 2016 14:49:48 +0000 (17:49 +0300)
committerAlbert <asyriy@mirantis.com>
Thu, 2 Jun 2016 15:05:29 +0000 (18:05 +0300)
Closes-bug: #1587960

Change-Id: I0091f8644ef15f5b14fa2dbab4c866ab1507acb1

cirros-testvm/cirros-u14.04-kver-3.13.0-85-x86_64-disk.img
cirros-testvm/src-cirros/src/lib/cirros/ds/configdrive
debian/changelog

index f673522ba9e684c6cf779efbee30289defb0dffa..882db6a0d56611e56a7502c466e56b5def2fe618 100644 (file)
Binary files a/cirros-testvm/cirros-u14.04-kver-3.13.0-85-x86_64-disk.img and b/cirros-testvm/cirros-u14.04-kver-3.13.0-85-x86_64-disk.img differ
index 9bc201d0ba96db12f8a52b7f393263e380338659..e2385038287912960289dd7fbfa8d06d8be38ab2 100755 (executable)
@@ -4,6 +4,7 @@ VERBOSITY=0
 CONFIG=/etc/cirros-init/configdrive
 NAME="${0##*/}"
 LABEL="config-2"
+LABEL_ALT="CONFIG-2"
 SEED_PRE_D="/var/lib/cloud/seed/configdrive-pre"
 SEED_POST_D="/var/lib/cloud/seed/configdrive"
 
@@ -22,7 +23,8 @@ search_local() {
        local out_d="$1"
        local devlist="" num="" found="" fstree_d=""
        local raw_d="" dev="" rdir="" mdjson="" ud="" found=""
-       find_devs_with "LABEL=$LABEL" ||
+       find_devs_with "LABEL=$LABEL" && [ -n "${_RET}" ] ||
+                find_devs_with "LABEL=$LABEL_ALT" ||
                { error "failed to find devs"; return 1; }
 
        devlist=${_RET}
@@ -61,7 +63,7 @@ search_local() {
                if [ -f "$mdjson" ]; then
                        json2fstree "$fstree_d" "$mdjson" ||
                                fail "json2fstree failed on $mdjson for $dev"
-                       ud="$rdir/openstack/latest/user_data" 
+                       ud="$rdir/openstack/latest/user_data"
                        [ -f "$ud" ] && cp "$ud" "$fstree_d/user-data"
                        found="$dev"
                        mv "$rdir" "$raw_d" ||
index d77ed53abfbb678c93525b821b8d1bbc2b99b50d..e94475ce0702d9e7a0431fd4c7a5a4bd78aeab75 100644 (file)
@@ -1,3 +1,10 @@
+cirros-testvm (0.3.4-2~u14.04+mos5) mos; urgency=medium
+
+  * Fix for file injection is broken on centos computes with Cirros images 
+    LP#1571704 
+
+ -- Albert Syriy <asyriy@mirantis.com>  Mon, 2 Jun 2016 17:55:15 +0200
+
 cirros-testvm (0.3.4-2~u14.04+mos4) mos9.0; urgency=medium
 
   * Add image size up to 48M due to the LP#1571704