Added in 5.0 for migrate to ruby-2.1 4.1.2 5.0 5.0.1 5.0.2
authorSergey Otpuschennikov <sotpuschennikov@mirantis.com>
Tue, 29 Apr 2014 09:25:20 +0000 (13:25 +0400)
committerSergey Otpuschennikov <sotpuschennikov@mirantis.com>
Tue, 29 Apr 2014 09:25:20 +0000 (13:25 +0400)
Change-Id: I3403a258923b3c313dd5870efe619ecafe5787f5

amqp-0.9.10.gem [new file with mode: 0644]
rubygem-amqp.spec [new file with mode: 0644]
test/runtest.sh [new file with mode: 0755]

diff --git a/amqp-0.9.10.gem b/amqp-0.9.10.gem
new file mode 100644 (file)
index 0000000..804c569
Binary files /dev/null and b/amqp-0.9.10.gem differ
diff --git a/rubygem-amqp.spec b/rubygem-amqp.spec
new file mode 100644 (file)
index 0000000..5d93e5f
--- /dev/null
@@ -0,0 +1,301 @@
+%define rbname amqp
+%define version 0.9.10
+%define release 1
+%global gemdir %(ruby -rubygems -e 'puts Gem::dir' 2>/dev/null)
+%global geminstdir %{gemdir}/gems/%{gemname}-%{version}
+%define gembuilddir %{buildroot}%{gemdir}
+
+Summary: Widely used, feature-rich asynchronous RabbitMQ client with batteries included
+Name: ruby21-rubygem-%{rbname}
+
+Version: %{version}
+Release: %{release}%{dist}
+Group: Development/Ruby
+License: Distributable
+URL: http://rubyamqp.info
+Source0: %{rbname}-%{version}.gem
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+Requires: ruby >= 2.1
+Requires: rubygems >= 2.1
+
+Requires: ruby21-rubygem-eventmachine 
+
+Requires: ruby21-rubygem-amq-client => 0.9.12
+Requires: ruby21-rubygem-amq-client < 0.10
+
+Requires: ruby21-rubygem-amq-protocol => 1.2.0
+Requires: ruby21-rubygem-amq-protocol < 1.3
+BuildRequires: ruby >= 2.1
+BuildRequires: rubygems >= 2.1
+BuildArch: noarch
+Provides: ruby21-rubygem(amqp) = %{version}
+
+
+%description
+Widely used, feature-rich asynchronous AMQP RabbitMQ client with batteries
+included.
+
+
+%prep
+%setup -T -c
+
+%build
+
+%install
+%{__rm} -rf %{buildroot}
+mkdir -p %{gembuilddir}
+gem install --local --install-dir %{gembuilddir} --force %{SOURCE0}
+
+%clean
+%{__rm} -rf %{buildroot}
+
+%files
+%defattr(-, root, root)
+%{gemdir}/gems/amqp-0.9.10/.gitignore
+%{gemdir}/gems/amqp-0.9.10/.rspec
+%{gemdir}/gems/amqp-0.9.10/.travis.yml
+%{gemdir}/gems/amqp-0.9.10/.yardopts
+%{gemdir}/gems/amqp-0.9.10/CHANGELOG
+%{gemdir}/gems/amqp-0.9.10/Gemfile
+%doc %{gemdir}/gems/amqp-0.9.10/README.md
+%{gemdir}/gems/amqp-0.9.10/Rakefile
+%{gemdir}/gems/amqp-0.9.10/amqp.gemspec
+%{gemdir}/gems/amqp-0.9.10/bin/ci/before_build.sh
+%{gemdir}/gems/amqp-0.9.10/bin/cleanify.rb
+%{gemdir}/gems/amqp-0.9.10/bin/docup
+%{gemdir}/gems/amqp-0.9.10/bin/irb
+%{gemdir}/gems/amqp-0.9.10/bin/set_test_suite_realms_up.sh
+%doc %{gemdir}/gems/amqp-0.9.10/docs/08Migration.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/AMQP091ModelExplained.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/Bindings.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/Clustering.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/ConnectingToTheBroker.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/ConnectionEncryptionWithTLS.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/DocumentationGuidesIndex.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/Durability.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/ErrorHandling.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/Exchanges.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/GettingStarted.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/PatternsAndUseCases.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/Queues.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/RabbitMQVersions.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/RunningTests.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/TestingWithEventedSpec.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/Troubleshooting.textile
+%doc %{gemdir}/gems/amqp-0.9.10/docs/VendorSpecificExtensions.textile
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/001_hello_world_example_routing.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/002_blabbr_example_routing.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/003_weathr_example_routing.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/004_fanout_exchange.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/005_direct_exchange.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/006_amqp_091_message_acknowledgements.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/007_rabbitmq_publisher_confirms.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/redhat/direct_exchange.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/redhat/fanout_exchange.png
+%{gemdir}/gems/amqp-0.9.10/docs/diagrams/redhat/topic_exchange.png
+%{gemdir}/gems/amqp-0.9.10/examples/channels/open_channel_with_one_arity_callback.rb
+%{gemdir}/gems/amqp-0.9.10/examples/channels/open_channel_without_assignment.rb
+%{gemdir}/gems/amqp-0.9.10/examples/channels/prefetch_as_constructor_argument.rb
+%{gemdir}/gems/amqp-0.9.10/examples/channels/qos_aka_prefetch.rb
+%{gemdir}/gems/amqp-0.9.10/examples/channels/qos_aka_prefetch_without_callback.rb
+%{gemdir}/gems/amqp-0.9.10/examples/connection/connect_and_immediately_disconnect.rb
+%{gemdir}/gems/amqp-0.9.10/examples/deprecated/default_thread_local_channel_instance.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/automatic_recovery_of_channel_and_queues.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/automatically_recovering_hello_world_consumer.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/automatically_recovering_hello_world_consumer_that_uses_a_server_named_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/basic_connection_failover.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/channel_level_exception.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/channel_level_exception_with_multiple_channels_involved.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/connection_level_exception.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/connection_level_exception_with_objects.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/connection_loss_handler.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/global_channel_level_exception_handler.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/handling_authentication_failure_with_a_callback.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/handling_authentication_failure_with_a_rescue_block.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/handling_vhost_misconfiguration_with_a_rescue_block.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/hello_world_producer.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/insufficient_permissions.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/manual_connection_and_channel_recovery.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/queue_exclusivity_violation.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/queue_name_violation.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/reopening_a_channel_after_channel_level_exception.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/tcp_connection_failure_handling_with_a_rescue_block.rb
+%{gemdir}/gems/amqp-0.9.10/examples/error_handling/tcp_connection_failure_with_a_callback.rb
+%{gemdir}/gems/amqp-0.9.10/examples/exchanges/autodeletion_of_exchanges.rb
+%{gemdir}/gems/amqp-0.9.10/examples/exchanges/declare_an_exchange_without_assignment.rb
+%{gemdir}/gems/amqp-0.9.10/examples/extensions/rabbitmq/per_queue_message_ttl.rb
+%{gemdir}/gems/amqp-0.9.10/examples/extensions/rabbitmq/publisher_confirmations_with_transient_messages.rb
+%{gemdir}/gems/amqp-0.9.10/examples/extensions/rabbitmq/using_alternate_exchanges.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/getting_started/01_hello_world.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/getting_started/02_hello_world_dslified.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/getting_started/03_blabbr.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/getting_started/04_weathr.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/01a_declaring_a_server_named_queue_using_queue_constructor.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/01b_declaring_a_queue_using_queue_constructor.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/02a_declaring_a_durable_shared_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/02b_declaring_a_durable_shared_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/03a_declaring_a_temporary_exclusive_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/03b_declaring_a_temporary_exclusive_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/04_bind_a_queue_using_exchange_instance.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/05_bind_a_queue_using_exchange_name.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/06_subscribe_to_receive_messages.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/07_fetch_a_message_from_the_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/08_unsubscribing_a_consumer.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/09_unbinding_from_exchange.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/10_purge_a_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/11_deleting_a_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/12_objects_that_consume_messages.rb
+%{gemdir}/gems/amqp-0.9.10/examples/guides/queues/13_objects_that_consume_messages_take_two.rb
+%{gemdir}/gems/amqp-0.9.10/examples/hello_world.rb
+%{gemdir}/gems/amqp-0.9.10/examples/hello_world_with_an_empty_string.rb
+%{gemdir}/gems/amqp-0.9.10/examples/hello_world_with_eventmachine_in_a_separate_thread.rb
+%{gemdir}/gems/amqp-0.9.10/examples/hello_world_with_large_payload.rb
+%{gemdir}/gems/amqp-0.9.10/examples/inspecting_server_information.rb
+%{gemdir}/gems/amqp-0.9.10/examples/issues/amq_client_issue_7.rb
+%{gemdir}/gems/amqp-0.9.10/examples/issues/amq_protocol_issue_14.rb
+%{gemdir}/gems/amqp-0.9.10/examples/issues/issue_75.rb
+%{gemdir}/gems/amqp-0.9.10/examples/issues/issue_79.rb
+%{gemdir}/gems/amqp-0.9.10/examples/issues/issue_80.rb
+%{gemdir}/gems/amqp-0.9.10/examples/issues/issue_93.rb
+%{gemdir}/gems/amqp-0.9.10/examples/issues/issue_94.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/ack.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/callbacks.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/clock.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/hashtable.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/logger.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/multiclock.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/pingpong.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/primes-simple.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/primes.rb
+%{gemdir}/gems/amqp-0.9.10/examples/legacy/stocks.rb
+%{gemdir}/gems/amqp-0.9.10/examples/patterns/command/consumer.rb
+%{gemdir}/gems/amqp-0.9.10/examples/patterns/command/producer.rb
+%{gemdir}/gems/amqp-0.9.10/examples/patterns/event/consumer.rb
+%{gemdir}/gems/amqp-0.9.10/examples/patterns/event/producer.rb
+%{gemdir}/gems/amqp-0.9.10/examples/patterns/request_reply/client.rb
+%{gemdir}/gems/amqp-0.9.10/examples/patterns/request_reply/server.rb
+%{gemdir}/gems/amqp-0.9.10/examples/publishing/publishing_a_one_off_message.rb
+%{gemdir}/gems/amqp-0.9.10/examples/publishing/publishing_callback.rb
+%{gemdir}/gems/amqp-0.9.10/examples/publishing/returned_messages.rb
+%{gemdir}/gems/amqp-0.9.10/examples/publishing/simplistic_scatter_gather.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/accessing_message_metadata.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/automatic_binding_for_default_direct_exchange.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/basic_get.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/cancel_default_consumer.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/declare_a_queue_without_assignment.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/declare_and_bind_a_server_named_queue.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/queue_status.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/rejecting_messages_without_requeueuing.rb
+%{gemdir}/gems/amqp-0.9.10/examples/queues/using_explicit_acknowledgements.rb
+%{gemdir}/gems/amqp-0.9.10/examples/rack/publish_a_message_on_request/thin.ru
+%{gemdir}/gems/amqp-0.9.10/examples/routing/fanout_routing.rb
+%{gemdir}/gems/amqp-0.9.10/examples/routing/headers_routing.rb
+%{gemdir}/gems/amqp-0.9.10/examples/routing/pubsub.rb
+%{gemdir}/gems/amqp-0.9.10/examples/routing/round_robin_with_direct_exchange.rb
+%{gemdir}/gems/amqp-0.9.10/examples/routing/round_robin_with_the_default_exchange.rb
+%{gemdir}/gems/amqp-0.9.10/examples/routing/unroutable_mandatory_message_is_returned.rb
+%{gemdir}/gems/amqp-0.9.10/examples/routing/weather_updates.rb
+%{gemdir}/gems/amqp-0.9.10/examples/tls/using_tls.rb
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/client/cert.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/client/key.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/client/keycert.p12
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/client/req.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/server/cert.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/server/key.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/server/keycert.p12
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/server/req.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/cacert.cer
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/cacert.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/certs/01.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/certs/02.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/index.txt
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/index.txt.attr
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/index.txt.attr.old
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/index.txt.old
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/openssl.cnf
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/private/cakey.pem
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/serial
+%{gemdir}/gems/amqp-0.9.10/examples/tls_certificates/testca/serial.old
+%{gemdir}/gems/amqp-0.9.10/lib/amqp.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/bit_set.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/broker.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/channel.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/client.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/compatibility/ruby187_patchlevel_check.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/connection.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/consumer.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/deprecated/fork.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/deprecated/logger.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/deprecated/mq.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/deprecated/rpc.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/exceptions.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/exchange.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/ext/em.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/ext/emfork.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/extensions/rabbitmq.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/header.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/int_allocator.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/integration/rails.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/logger.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/queue.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/rpc.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/session.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/utilities/event_loop_helper.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/utilities/server_type.rb
+%{gemdir}/gems/amqp-0.9.10/lib/amqp/version.rb
+%{gemdir}/gems/amqp-0.9.10/lib/mq.rb
+%{gemdir}/gems/amqp-0.9.10/lib/mq/logger.rb
+%{gemdir}/gems/amqp-0.9.10/lib/mq/rpc.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/authentication_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/automatic_binding_for_default_direct_exchange_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/automatic_recovery_predicate_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/basic_get_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/basic_return_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/channel_close_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/channel_level_exception_handling_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/channel_level_exception_with_multiple_channels_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/connection_level_exception_handling_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/declare_and_immediately_bind_a_server_named_queue_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/declare_one_hundred_server_named_queues_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/direct_exchange_routing_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/exchange_declaration_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/extensions/rabbitmq/publisher_confirmations_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/fanout_exchange_routing_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/headers_exchange_routing_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/hello_world_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/mandatory_messages_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/message_acknowledgement_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/message_metadata_access_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/multiple_consumers_per_queue_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/ordering_of_published_messages_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/queue_declaration_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/queue_exclusivity_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/queue_redeclaration_with_incompatible_attributes_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/queue_status_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/recovery/per_channel_automatic_recovery_on_graceful_broker_shutdown_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/recovery/per_channel_automatic_recovery_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/redelivery_of_unacknowledged_messages_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/regressions/concurrent_publishing_on_the_same_channel_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/regressions/empty_message_body_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/regressions/issue66_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/remove_individual_binding_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/reply_queue_communication_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/store_and_forward_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/stress/publishing_of_messages_with_incrementing_sizes_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/topic_subscription_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/tx_commit_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/integration/tx_rollback_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/spec_helper.rb
+%{gemdir}/gems/amqp-0.9.10/spec/unit/amqp/bit_set_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/unit/amqp/channel_id_allocation_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/unit/amqp/client_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/unit/amqp/connection_spec.rb
+%{gemdir}/gems/amqp-0.9.10/spec/unit/amqp/int_allocator_spec.rb
+
+
+%doc %{gemdir}/doc/amqp-0.9.10
+%{gemdir}/cache/amqp-0.9.10.gem
+%{gemdir}/specifications/amqp-0.9.10.gemspec
+
+%changelog
+
diff --git a/test/runtest.sh b/test/runtest.sh
new file mode 100755 (executable)
index 0000000..bfc9d9c
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/bash -x
+RES=0
+case $1 in
+ruby21-rubygem-amqp)
+    echo "Testing $1"
+    ruby -r 'rubygems' -e "require 'amqp'"
+    RES=$?
+;;
+*)
+    echo "test not defined, skipping..."
+;;
+esac
+exit $RES