dpkg backported from centos7 to obtain compatibility
[packages/centos6/dpkg.git] / dpkg.spec
1 %global pkgconfdir      %{_sysconfdir}/dpkg
2 %global pkgdatadir      %{_datadir}/dpkg
3
4 Name:           dpkg
5 Version:        1.16.16
6 Release:        5%{?dist}~mos8.0.1
7 Summary:        Package maintenance system for Debian Linux
8 Group:          System Environment/Base
9 # The entire source code is GPLv2+ with exception of the following
10 # lib/dpkg/md5.c, lib/dpkg/md5.h - Public domain
11 # lib/dpkg/showpkg.c, dselect/methods/multicd, lib/dpkg/utils.c, lib/dpkg/showpkg.c - GPLv2
12 # dselect/methods/ftp - GPL no version info
13 # scripts/Dpkg/Gettext.pm - BSD
14 # lib/compat/obstack.h, lib/compat/gettext.h,lib/compat/obstack.c - LGPLv2+
15 License:        GPLv2 and GPLv2+ and LGPLv2+ and Public Domain and BSD
16 URL:            https://tracker.debian.org/pkg/dpkg
17 Source0:        http://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
18 Patch0:         dpkg-perl-libexecdir.patch
19 Patch1:         dpkg-fix-logrotate.patch
20 Patch2:         dpkg-perl-libexecdir.epel6.patch
21 BuildRequires:  zlib-devel bzip2-devel libselinux-devel gettext ncurses-devel
22 BuildRequires:  autoconf automake gettext-devel
23 BuildRequires:  doxygen flex xz-devel po4a
24 %if 0%{?rhel} != 5 && 0%{?rhel} != 6
25 BuildRequires:  dotconf-devel
26 %endif
27 # for /usr/bin/pod2man
28 %if 0%{?fedora} > 18
29 BuildRequires: perl-podlators
30 %else
31 BuildRequires: perl
32 %endif
33
34 %description
35 This package contains the tools (including dpkg-source) required
36 to unpack, build and upload Debian source packages.
37
38 This package also contains the programs dpkg which used to handle the
39 installation and removal of packages on a Debian system.
40
41 This package also contains dselect, an interface for managing the
42 installation and removal of packages on the system.
43
44 dpkg and dselect will certainly be non-functional on a rpm-based system
45 because packages dependencies will likely be unmet.
46
47 %package devel
48 Summary: Debian package management static library
49 Group:    Development/System
50 Provides: dpkg-static = %{version}-%{release}
51
52 %description devel
53 This package provides the header files and static library necessary to
54 develop software using dpkg, the same library used internally by dpkg.
55
56 Note though, that the API is to be considered volatile, and might change
57 at any time, use at your own risk.
58
59
60 %package dev
61 Summary:  Debian package development tools
62 Group:    Development/System
63 Requires: dpkg-perl = %{version}-%{release}
64 Requires: patch, make, binutils, bzip2, lzma, xz
65 Obsoletes: dpkg-devel < 1.16
66 BuildArch: noarch
67
68 %description dev
69 This package provides the development tools (including dpkg-source).
70 Required to unpack, build and upload Debian source packages
71
72 %package perl
73 Summary: Dpkg perl modules
74 Group:   System Environment/Base
75 Requires: dpkg = %{version}-%{release}
76 Requires: perl, perl-TimeDate
77 BuildArch: noarch
78
79 %description perl
80 This package provides the perl modules used by the scripts
81 in dpkg-dev. They cover a wide range of functionalities. Among them
82 there are the following modules:
83   - Dpkg::Arch: manipulate Debian architecture information
84   - Dpkg::BuildOptions: parse and manipulate DEB_BUILD_OPTIONS
85   - Dpkg::Changelog: parse Debian changelogs
86   - Dpkg::Checksums: generate and parse checksums
87   - Dpkg::Compression::Process: wrapper around compression tools
88   - Dpkg::Compression::FileHandle: transparently (de)compress files
89   - Dpkg::Control: parse and manipulate Debian control information
90     (.dsc, .changes, Packages/Sources entries, etc.)
91   - Dpkg::Deps: parse and manipulate dependencies
92   - Dpkg::ErrorHandling: common error functions
93   - Dpkg::Index: collections of Dpkg::Control (Packages/Sources files for
94     example)
95   - Dpkg::IPC: spawn sub-processes and feed/retrieve data
96   - Dpkg::Substvars: substitute variables in strings
97   - Dpkg::Vendor: identify current distribution vendor
98   - Dpkg::Version: parse and manipulate Debian package versions
99
100 %package -n dselect
101 Summary:  Debian package management front-end
102 Group:    System Environment/Base
103 Requires: %{name} = %{version}-%{release}
104
105 %description -n dselect
106 dselect is a high-level interface for the installation/removal of debs .
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112 %if 0%{?rhel} <= 6
113 %patch2 -p1
114 %endif
115
116 # Filter unwanted Requires:
117 cat << \EOF > %{name}-req
118 #!/bin/sh
119 %{__perl_requires} $* |\
120   sed -e '/perl(Dselect::Ftp)/d' -e '/perl(extra)/d' -e '/perl(file)/d' -e '/perl(dpkg-gettext.pl)/d' -e '/perl(controllib.pl)/d' -e '/perl(in)/d'
121 EOF
122
123 %define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
124 chmod +x %{__perl_requires}
125
126 %build
127 %if 0%{?rhel} != 5 && 0%{?rhel} != 6
128 # We can't run autoreconf on epel <= 6 because needs gettext-0.18 when epel6
129 # only have gettext-0.17:
130 # autopoint: *** The AM_GNU_GETTEXT_VERSION declaration in your configure.ac
131 # file requires the infrastructure from gettext-0.18 but this version
132 # is older. Please upgrade to gettext-0.18 or newer.
133 autoreconf -fiv
134 %endif
135 %configure --disable-start-stop-daemon \
136         --disable-linker-optimisations \
137         --with-admindir=%{_localstatedir}/lib/dpkg \
138         --with-selinux \
139         --with-zlib \
140         --with-bz2
141
142 make %{?_smp_mflags}
143
144
145 %install
146 make install DESTDIR=%{buildroot}
147
148 mkdir -p %{buildroot}/%{pkgconfdir}/dpkg.cfg.d
149 mkdir -p %{buildroot}/%{pkgconfdir}/dselect.cfg.d
150 mkdir -p %{buildroot}/%{pkgconfdir}/origins
151
152 # Prepare "vendor" files for dpkg-vendor
153 cat <<EOF > %{buildroot}/%{pkgconfdir}/origins/fedora
154 Vendor: Fedora
155 Vendor-URL: http://www.fedoraproject.org/
156 Bugs: https://bugzilla.redhat.com
157 EOF
158 %if 0%{?fedora}
159 ln -sf fedora %{buildroot}/%{pkgconfdir}/origins/default
160 %endif
161
162 # from debian/dpkg.install
163 install -pm0644 debian/archtable %{buildroot}/%{pkgdatadir}/archtable
164 install -pm0644 debian/dpkg.cfg %{buildroot}/%{pkgconfdir}
165 install -pm0644 debian/shlibs.default %{buildroot}/%{pkgconfdir}
166 install -pm0644 debian/shlibs.override %{buildroot}/%{pkgconfdir}
167
168 # patched debian/dpkg.logrotate
169 mkdir -p %{buildroot}/%{_sysconfdir}/logrotate.d
170 install -pm0644 debian/dpkg.logrotate %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
171
172
173 %find_lang dpkg
174 %find_lang dpkg-dev
175 %find_lang dselect
176
177 # fedora has its own implementation
178 rm %{buildroot}%{_bindir}/update-alternatives
179 rm %{buildroot}%{_mandir}/man8/update-alternatives.8
180 rm -rf %{buildroot}%{_mandir}/*/man8/update-alternatives.8
181 rm -rf %{buildroot}%{_sysconfdir}/alternatives/
182
183 #fedora has own implemenation
184 #FIXME should we remove this ?
185 rm -rf %{buildroot}%{_sbindir}/install-info
186
187 mkdir -p %{buildroot}%{_localstatedir}/lib/dpkg/alternatives %{buildroot}%{_localstatedir}/lib/dpkg/info \
188  %{buildroot}%{_localstatedir}/lib/dpkg/parts %{buildroot}%{_localstatedir}/lib/dpkg/updates \
189  %{buildroot}%{_localstatedir}/lib/dpkg/methods
190
191
192 %post
193 # from dpkg.postinst
194 # Create the database files if they don't already exist
195 create_database() {
196     admindir=${DPKG_ADMINDIR:-/var/lib/dpkg}
197
198     for file in diversions statoverride status; do
199     if [ ! -f "$admindir/$file" ]; then
200         touch "$admindir/$file"
201     fi
202     done
203 }
204
205 # Create log file and set default permissions if possible
206 create_logfile() {
207     logfile=/var/log/dpkg.log
208     touch $logfile
209     chmod 644 $logfile
210     chown root:root $logfile 2>/dev/null || chown 0:0 $logfile
211 }
212 create_database
213 create_logfile
214
215
216 %files   -f dpkg.lang
217 %defattr(-,root,root,-)
218 %doc debian/changelog README AUTHORS THANKS TODO
219 %doc debian/copyright debian/usertags
220 %doc doc/README.feature-removal-schedule doc/triggers.txt
221 %dir %{pkgconfdir}
222 %dir %{pkgconfdir}/dpkg.cfg.d
223 %dir %{pkgconfdir}/origins
224 %config(noreplace) %{pkgconfdir}/dpkg.cfg
225 %config(noreplace) %{pkgconfdir}/origins/*
226 %config(noreplace) %{_sysconfdir}/logrotate.d/dpkg
227 %{_bindir}/dpkg
228 %{_bindir}/dpkg-deb
229 %{_bindir}/dpkg-maintscript-helper
230 %{_bindir}/dpkg-query
231 %{_bindir}/dpkg-split
232 %{_bindir}/dpkg-trigger
233 %{_bindir}/dpkg-divert
234 %{_bindir}/dpkg-statoverride
235 %dir %{pkgdatadir}
236 %{pkgdatadir}/abitable
237 %{pkgdatadir}/archtable
238 %{pkgdatadir}/cputable
239 %{pkgdatadir}/ostable
240 %{pkgdatadir}/triplettable
241 %dir %{_localstatedir}/lib/dpkg/alternatives
242 %dir %{_localstatedir}/lib/dpkg/info
243 %dir %{_localstatedir}/lib/dpkg/parts
244 %dir %{_localstatedir}/lib/dpkg/updates
245 %{_mandir}/man1/dpkg.1.gz
246 %{_mandir}/man1/dpkg-deb.1.gz
247 %{_mandir}/man1/dpkg-maintscript-helper.1.gz
248 %{_mandir}/man1/dpkg-query.1.gz
249 %{_mandir}/man1/dpkg-split.1.gz
250 %{_mandir}/man1/dpkg-trigger.1.gz
251 %{_mandir}/man5/dpkg.cfg.5.gz
252 %{_mandir}/man8/dpkg-divert.8.gz
253 %{_mandir}/man8/dpkg-statoverride.8.gz
254 %{_mandir}/*/man1/dpkg.1.gz
255 %{_mandir}/*/man1/dpkg-deb.1.gz
256 %{_mandir}/*/man1/dpkg-maintscript-helper.1.gz
257 %{_mandir}/*/man1/dpkg-query.1.gz
258 %{_mandir}/*/man1/dpkg-split.1.gz
259 %{_mandir}/*/man1/dpkg-trigger.1.gz
260 %{_mandir}/*/man5/dpkg.cfg.5.gz
261 %{_mandir}/*/man8/dpkg-divert.8.gz
262 %{_mandir}/*/man8/dpkg-statoverride.8.gz
263
264 %files devel
265 %defattr(-,root,root,-)
266 %{_libdir}/libdpkg.a
267 %{_libdir}/pkgconfig/libdpkg.pc
268 %{_includedir}/dpkg/*.h
269
270 %files dev
271 %defattr(-,root,root,-)
272 %doc doc/README.api doc/coding-style.txt doc/frontend.txt
273 %config(noreplace) %{pkgconfdir}/shlibs.default
274 %config(noreplace) %{pkgconfdir}/shlibs.override
275 %{_bindir}/dpkg-architecture
276 %{_bindir}/dpkg-buildpackage
277 %{_bindir}/dpkg-buildflags
278 %{_bindir}/dpkg-checkbuilddeps
279 %{_bindir}/dpkg-distaddfile
280 %{_bindir}/dpkg-genchanges
281 %{_bindir}/dpkg-gencontrol
282 %{_bindir}/dpkg-gensymbols
283 %{_bindir}/dpkg-mergechangelogs
284 %{_bindir}/dpkg-name
285 %{_bindir}/dpkg-parsechangelog
286 %{_bindir}/dpkg-scanpackages
287 %{_bindir}/dpkg-scansources
288 %{_bindir}/dpkg-shlibdeps
289 %{_bindir}/dpkg-source
290 %{_bindir}/dpkg-vendor
291 %{_libexecdir}/dpkg/parsechangelog
292 %{pkgdatadir}/*.mk
293 %{_mandir}/man1/dpkg-architecture.1.gz
294 %{_mandir}/man1/dpkg-buildflags.1.gz
295 %{_mandir}/man1/dpkg-buildpackage.1.gz
296 %{_mandir}/man1/dpkg-checkbuilddeps.1.gz
297 %{_mandir}/man1/dpkg-distaddfile.1.gz
298 %{_mandir}/man1/dpkg-genchanges.1.gz
299 %{_mandir}/man1/dpkg-gencontrol.1.gz
300 %{_mandir}/man1/dpkg-gensymbols.1.gz
301 %{_mandir}/man1/dpkg-mergechangelogs.1.gz
302 %{_mandir}/man1/dpkg-name.1.gz
303 %{_mandir}/man1/dpkg-parsechangelog.1.gz
304 %{_mandir}/man1/dpkg-scanpackages.1.gz
305 %{_mandir}/man1/dpkg-scansources.1.gz
306 %{_mandir}/man1/dpkg-shlibdeps.1.gz
307 %{_mandir}/man1/dpkg-source.1.gz
308 %{_mandir}/man1/dpkg-vendor.1.gz
309 %{_mandir}/man5/deb-control.5.gz
310 %{_mandir}/man5/deb-extra-override.5.gz
311 %{_mandir}/man5/deb-old.5.gz
312 %{_mandir}/man5/deb-origin.5.gz
313 %{_mandir}/man5/deb-override.5.gz
314 %{_mandir}/man5/deb-shlibs.5.gz
315 %{_mandir}/man5/deb-split.5.gz
316 %{_mandir}/man5/deb-src-control.5.gz
317 %{_mandir}/man5/deb-substvars.5.gz
318 %{_mandir}/man5/deb-symbols.5.gz
319 %{_mandir}/man5/deb-triggers.5.gz
320 %{_mandir}/man5/deb-version.5.gz
321 %{_mandir}/man5/deb.5.gz
322 %{_mandir}/*/man1/dpkg-architecture.1.gz
323 %{_mandir}/*/man1/dpkg-buildpackage.1.gz
324 %{_mandir}/*/man1/dpkg-buildflags.1.gz
325 %{_mandir}/*/man1/dpkg-checkbuilddeps.1.gz
326 %{_mandir}/*/man1/dpkg-distaddfile.1.gz
327 %{_mandir}/*/man1/dpkg-genchanges.1.gz
328 %{_mandir}/*/man1/dpkg-gencontrol.1.gz
329 %{_mandir}/*/man1/dpkg-gensymbols.1.gz
330 %{_mandir}/*/man1/dpkg-mergechangelogs.1.gz
331 %{_mandir}/*/man1/dpkg-name.1.gz
332 %{_mandir}/*/man1/dpkg-parsechangelog.1.gz
333 %{_mandir}/*/man1/dpkg-scanpackages.1.gz
334 %{_mandir}/*/man1/dpkg-scansources.1.gz
335 %{_mandir}/*/man1/dpkg-shlibdeps.1.gz
336 %{_mandir}/*/man1/dpkg-source.1.gz
337 %{_mandir}/*/man1/dpkg-vendor.1.gz
338 %{_mandir}/*/man5/deb-control.5.gz
339 %{_mandir}/*/man5/deb-extra-override.5.gz
340 %{_mandir}/*/man5/deb-old.5.gz
341 %{_mandir}/*/man5/deb-origin.5.gz
342 %{_mandir}/*/man5/deb-override.5.gz
343 %{_mandir}/*/man5/deb-shlibs.5.gz
344 %{_mandir}/*/man5/deb-split.5.gz
345 %{_mandir}/*/man5/deb-src-control.5.gz
346 %{_mandir}/*/man5/deb-substvars.5.gz
347 %{_mandir}/*/man5/deb-symbols.5.gz
348 %{_mandir}/*/man5/deb-triggers.5.gz
349 %{_mandir}/*/man5/deb-version.5.gz
350 %{_mandir}/*/man5/deb.5.gz
351
352 %files perl -f dpkg-dev.lang
353 %defattr(-,root,root,-)
354 %{perl_vendorlib}/Dpkg*
355 %{_mandir}/man3/Dpkg*.3*
356
357 %files -n dselect -f dselect.lang
358 %defattr(-,root,root,-)
359 %doc dselect/methods/multicd/README.multicd dselect/methods/ftp/README.mirrors.txt
360 %{_bindir}/dselect
361 %{perl_vendorlib}/Debian
362 %{_libdir}/dpkg/methods
363 %{_mandir}/man1/dselect.1.gz
364 %{_mandir}/*/man1/dselect.1.gz
365 %{_mandir}/man5/dselect.cfg.5.gz
366 %{_mandir}/*/man5/dselect.cfg.5.gz
367 %dir %{pkgconfdir}/dselect.cfg.d
368 %{_localstatedir}/lib/dpkg/methods
369
370
371 %changelog
372 * Wed Sep 30 2015 Ivan Suzdal <isuzdal@mirantis.com> - 1.16.16-5%{?dist}~mos8.0.1
373 - Rebuild for MOS 8.0
374 - Append ~mosX.X.X to Release
375
376 * Sun Apr 26 2015 Sérgio Basto <sergio@serjux.com> - 1.16.16-5
377 - Fix build for all versions, previous try wasn't correct and back with
378   dpkg-perl-libexecdir.patch .
379 - Added dpkg-perl-libexecdir.epel6.patch just for fix epel <= 6 .
380 - Cleaned some trailing whitespaces.
381 - Use _localstatedir instead /var .
382
383 * Sat Apr 25 2015 Sérgio Basto <sergio@serjux.com> - 1.16.16-4
384 - Revert location of dpkg/parsechangelog .
385 - Fix build for all versions, including epel-6 .
386
387 * Tue Apr 21 2015 Sérgio Basto <sergio@serjux.com> - 1.16.16-3
388 - Better upstream URL .
389
390 * Tue Apr 21 2015 Sérgio Basto <sergio@serjux.com> - 1.16.16-2
391 - Some fixes and added support for epel-6 .
392 - Removed Patch0: dpkg-perl-libexecdir.patch .
393 - move %{_libdir}/dpkg/parsechangelog to archable package .
394
395 * Sun Apr 19 2015 Sérgio Basto <sergio@serjux.com> - 1.16.16-1
396 - Security update to 1.16.16
397
398 * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16.15-2
399 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
400
401 * Mon Jun 23 2014 Sérgio Basto <sergio@serjux.com> - 1.16.15-1
402 - Update to 1.16.15, fixes: CVE-2014-3864, CVE-2014-3865 , rhbz #1103026
403
404 * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16.14-2
405 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
406
407 * Sat May 10 2014 Sérgio Basto <sergio@serjux.com> - 1.16.14-1
408 - Update to 1.16.14, fixes CVE-2014-0471, rhbz #1092210 .
409
410 * Wed Oct 16 2013 Sérgio Basto <sergio@serjux.com> - 1.16.12-1
411 - Update to 1.16.12
412 - added /etc/dpkg/origins/... , by Oron Peled, rhbz #973832
413 - fix few files listed twice.
414
415 * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16.10-8
416 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
417
418 * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 1.16.10-7
419 - Perl 5.18 rebuild
420
421 * Mon Jul 01 2013 Sérgio Basto <sergio@serjux.com> - 1.16.10-6
422 - add support to logrotate, by Oron Peled, rhbz #979378
423 - added some new %doc and debian/copyright, by Oron Peled, rhbz #979378
424 - rpmlint cleanups, by Oron Peled, rhbz #979378 
425
426 * Sun Jun 30 2013 Sérgio Basto <sergio@serjux.com> - 1.16.10-5
427 - rhbz #979378 
428   - Obsolete the old dpkg-devel.noarch (replaced by dpkg-dev)
429   (Obsoletes: dpkg-devel < 1.16)
430   - Readd to dpkg-perl: Requires: dpkg = <version>-<release>
431   - Patchset Signed-off-by: Oron Peled
432   - [PATCH 1/4] move dpkg.cfg from /etc to /etc/dpkg 
433   - [PATCH 2/4] fix some pkgdatadir, pkgconfdir file locations
434   - [PATCH 3/4] move "dpkg-dev.mo" files to dpkg-perl
435   - [PATCH 4/4] minor fix to dpkg-perl ownerships
436 - move from dpkg to dpkg-dev, rhbz #979378 
437   - dpkg-mergechangelogs and its man-pages
438   - dpkg-buildflags and its man-pages
439 - remove man pages dups, also rhbz #979378
440     dpkg-architecture.1.gz
441     dpkg-buildflags.1.gz
442     dpkg-buildpackage.1.gz
443     dpkg-checkbuilddeps.1.gz
444     dpkg-distaddfile.1.gz
445     dpkg-genchanges.1.gz
446     dpkg-gencontrol.1.gz
447     dpkg-gensymbols.1.gz
448     dpkg-mergechangelogs.1.gz
449     dpkg-name.1.gz
450     dpkg-parsechangelog.1.gz
451     dpkg-scanpackages.1.gz
452     dpkg-scansources.1.gz
453     dpkg-shlibdeps.1.gz
454     dpkg-source.1.gz
455     dpkg-vendor.1.gz
456
457 * Sun Jun 02 2013 Sérgio Basto <sergio@serjux.com> - 1.16.10-4
458 - provided virtual -static package rhbz #967215
459
460 * Tue May 21 2013 Sérgio Basto <sergio@serjux.com> - 1.16.10-3
461 - Copied from dpkg-1.16.10/debian/dpkg.postinst, on post install, runs create_database, create_logfile. 
462 - Based on dpkg.install and dselect.install
463   created some missing directories in /var/lib/dpkg and in /etc/dpkg .
464 - Drop Requirement dpkg of dpkg-perl.
465 - Fix a FIXME , all perls moved to dpkg-perl.
466 - TODO: set logrotates, see debian/dpkg.logrotate.
467
468 * Fri May 17 2013 Sérgio Basto <sergio@serjux.com> - 1.16.10-2
469 - apply fix by Oron Peled bug #648384, adds dpkg-perl as noarch
470
471 * Thu May 16 2013 Sérgio Basto <sergio@serjux.com> - 1.16.10-1
472 - Add BR perl-podlators for pod2man in F19 development or just BR perl
473 - Add some other importants BR: doxygen flex xz-devel po4a dotconf-devel
474 - Fix packages names which are debianized, so packages will be: dpkg-perl
475 and dpkg-dev (and dpkg-devel for headers of dpkg).
476 - Some clean ups.
477 - dpkg-perl must be arched.
478
479 * Sat May  4 2013 Oron Peled <oron@actcom.co.il>
480 - Bump version to Debian/wheezy
481 - Call autoreconf: make sure we don't reuse Debian packaged
482   stuff (config.guess, etc.)
483 - CVE patches not needed -- is already fixed upstream
484 - Removed dpkg-change-libdir.patch:
485   - Patching Makefile.in is wrong (can patch Makefile.am with autoreconf)
486   - Less patch churn for non-critical paths
487   - Accept /usr/lib/dpkg/parsechangelog
488   - Accept /usr/lib/dpkg/methods
489
490 * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15.5.6-10
491 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
492
493 * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15.5.6-9
494 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
495
496 * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15.5.6-8
497 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
498
499 * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15.5.6-7
500 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
501
502 * Wed Jan 12 2011 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-6
503 - Fix CVE-2010-1679
504 - Fix CVE-2011-0402
505
506 * Sun Oct 17 2010 Jeroen van Meeuwen <kanarip@kanarip.com> - 1.15.5.6-5
507 - Apply minimal fix for rhbz #642160
508
509 * Thu Mar 11 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-4
510 - Fix CVE-2010-0396
511
512 * Mon Feb 15 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-3
513 - review changes
514
515 * Sun Feb 14 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-2
516 - review changes
517
518 * Sat Feb 13 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-1
519 - Upgrade to latest upstream
520 - review changes
521
522 * Tue Nov 10 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.4.1-1
523 - Upgrade to latest upstream
524 - review changes
525
526 * Tue Dec 30 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.23-3
527 - more review changes               
528
529 * Mon Dec 15 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.23-1
530 - bump version and make some of the review changes
531
532 * Tue Aug 19 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-5
533 - made changes for review 
534
535 * Thu Jul 31 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-4
536 - Change release to -4 as server refused -3
537
538 * Thu Jul 31 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-3
539 - split the package into dkpg, dpkg-dev & dselect
540
541 * Tue Jul 29 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-2
542 - recode man files to UTF8
543
544 * Tue Jul 29 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-1
545 - Rebuild ans add build requires ncurses-devel
546
547 * Thu Jul 19 2007 Patrice Dumas <pertusus@free.fr> - 1.14.5-1
548 - initial packaging