Rebuild dpkg for 7.0.
[packages/centos6/dpkg.git] / dpkg.spec
1 Name:           dpkg
2 Version:        1.15.5.6
3 Release:        6%{?dist}.mira3
4 Summary:        Package maintenance system for Debian Linux
5 Group:          System Environment/Base
6 # The entire source code is GPLv2+ with exception of the following
7 # lib/dpkg/md5.c, lib/dpkg/md5.h - Public domain
8 # lib/dpkg/showpkg.c, dselect/methods/multicd, lib/dpkg/utils.c, lib/dpkg/showpkg.c - GPLv2
9 # dselect/methods/ftp - GPL no version info
10 # scripts/Dpkg/Gettext.pm - BSD
11 # lib/compat/obstack.h, lib/compat/gettext.h,lib/compat/obstack.c - LGPLv2+
12 License:        GPLv2 and GPLv2+ and LGPLv2+ and Public Domain and BSD
13 URL:            http://packages.debian.org/unstable/admin/dpkg
14 Source0:        http://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.bz2
15 # obtained from dpkg-source -x dpkg_1.15.5.6.dsc
16 Source1:        dpkg.archtable
17 # Fedora specific patch to store files under /usr/share/dpkg, not these are not binary
18 # libs. and set user search path to /usr/local/share/dpkg
19 Patch1:         dpkg-change-libdir-path.patch
20 # Fixes CVE-2010-0396 bugzilla #572522
21 Patch2:         fedora-fix-CVE-2010-0396-00.patch
22 Patch3:         fedora-fix-CVE-2010-0396-01.patch
23 Patch4:     fedora-bug642160-empty-argv.patch
24 Patch5:         fedora-fix-CVE-2010-1679_CVE-2011-0402.patch
25 Patch6:     MIRA0001-Allow-parcing-indices-override-files-when-architect.patch
26 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
27 BuildRequires:  zlib-devel, bzip2-devel, libselinux-devel, gettext, ncurses-devel
28
29 %description 
30
31 This package contains the tools (including dpkg-source) required 
32 to unpack, build and upload Debian source packages.
33
34 This package also contains the programs dpkg which used to handle the 
35 installation and removal of packages on a Debian system.
36
37 This package also contains dselect, an interface for managing the 
38 installation and removal of packages on the system.
39
40 dpkg and dselect will certainly be non-functional on a rpm-based system
41 because packages dependencies will likely be unmet.
42
43 %package devel
44 Summary:  Debian package development tools
45 Group:    Development/System
46 Requires: %{name} = %{version}-%{release}
47 Requires: perl, patch, make, binutils, bzip2, lzma
48 BuildArch: noarch
49
50 %description devel
51 This package provides the development tools (including dpkg-source).
52 Required to unpack, build and upload Debian source packages
53
54
55 %package -n dselect
56 Summary:  Debian package management front-end
57 Group:    System Environment/Base
58 Requires: %{name} = %{version}-%{release}
59
60 %description -n dselect
61 dselect is a high-level interface for the installation/removal of debs . 
62
63 %prep
64 %setup -q
65
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69 %patch4 -p1
70 %patch5 -p1
71 %patch6 -p1
72
73 # Filter unwanted Requires:
74 cat << \EOF > %{name}-req
75 #!/bin/sh
76 %{__perl_requires} $* |\
77   sed -e '/perl(Dselect::Ftp)/d' -e '/perl(extra)/d' -e '/perl(file)/d' -e '/perl(dpkg-gettext.pl)/d' -e '/perl(controllib.pl)/d' -e '/perl(in)/d'
78 EOF
79
80 %define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
81 chmod +x %{__perl_requires}
82
83 %build
84 %configure --without-start-stop-daemon \
85         --disable-linker-optimisations \
86         --with-admindir=%{_localstatedir}/lib/dpkg \
87         --libdir=%{_datadir} \
88         --with-selinux \
89         --with-zlib \
90         --with-bz2 \
91         --disable-silent-rules
92
93 make %{?_smp_mflags}
94
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 make install DESTDIR=$RPM_BUILD_ROOT
99 install -pm0644 %SOURCE1 $RPM_BUILD_ROOT/%{_datadir}/dpkg/archtable
100
101 %find_lang dpkg
102 %find_lang dpkg-dev
103 %find_lang dselect
104
105 # fedora has its own implementation
106 rm -rf $RPM_BUILD_ROOT%{_bindir}/update-alternatives
107 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112
113 %files   -f dpkg.lang
114 %defattr(-,root,root,-)
115 %doc debian/changelog README AUTHORS COPYING THANKS TODO
116 %dir %{_sysconfdir}/dpkg
117 %{_bindir}/dpkg
118 %{_bindir}/dpkg-deb
119 %{_bindir}/dpkg-query
120 %{_bindir}/dpkg-split
121 %{_bindir}/dpkg-trigger
122 %{_bindir}/dpkg-divert
123 %{_bindir}/dpkg-statoverride
124 %{_sbindir}/*
125 %dir %{_datadir}/dpkg
126 %{_datadir}/dpkg/mksplit
127 %{_datadir}/dpkg/archtable
128 %{_datadir}/dpkg/cputable
129 %{_datadir}/dpkg/ostable
130 %{_datadir}/dpkg/triplettable
131 %{perl_vendorlib}/Dpkg.pm
132 %dir %{perl_vendorlib}/Dpkg
133 %{perl_vendorlib}/Dpkg/Gettext.pm
134 %{_mandir}/man1/dpkg-deb.1.gz
135 %{_mandir}/man1/dpkg-query.1.gz
136 %{_mandir}/man1/dpkg-split.1.gz
137 %{_mandir}/man1/dpkg-trigger.1.gz
138 %{_mandir}/man1/dpkg.1.gz
139 %{_mandir}/man5/dpkg.cfg.5.gz
140 %{_mandir}/man8/dpkg-divert.8.gz
141 %{_mandir}/man8/dpkg-statoverride.8.gz
142 #fedora has own implemenation
143 %exclude %{_sbindir}/install-info
144 #fedora has own implemenation
145 %exclude %{_mandir}/man8/update-alternatives.8.gz
146
147 %files  devel -f dpkg-dev.lang
148 %defattr(-,root,root,-)
149 %doc doc/README.api
150 %{_bindir}/dpkg-architecture
151 %{_bindir}/dpkg-buildpackage
152 %{_bindir}/dpkg-checkbuilddeps
153 %{_bindir}/dpkg-distaddfile
154 %{_bindir}/dpkg-genchanges
155 %{_bindir}/dpkg-gencontrol
156 %{_bindir}/dpkg-gensymbols
157 %{_bindir}/dpkg-name
158 %{_bindir}/dpkg-parsechangelog
159 %{_bindir}/dpkg-scanpackages
160 %{_bindir}/dpkg-scansources
161 %{_bindir}/dpkg-shlibdeps
162 %{_bindir}/dpkg-source
163 %{_bindir}/dpkg-vendor
164 %dir %{_datadir}/dpkg/parsechangelog
165 %{_datadir}/dpkg/parsechangelog/*
166 %exclude %{perl_vendorlib}/Dpkg/Gettext.pm
167 %{perl_vendorlib}/Dpkg/*.pm
168 %{perl_vendorlib}/Dpkg/Changelog
169 %{perl_vendorlib}/Dpkg/Shlibs
170 %{perl_vendorlib}/Dpkg/Source
171 %{perl_vendorlib}/Dpkg/Vendor
172 %{perl_vendorlib}/Dpkg/Control
173 %{_mandir}/man1/dpkg-architecture.1.gz
174 %{_mandir}/man1/dpkg-buildpackage.1.gz
175 %{_mandir}/man1/dpkg-checkbuilddeps.1.gz
176 %{_mandir}/man1/dpkg-distaddfile.1.gz
177 %{_mandir}/man1/dpkg-genchanges.1.gz
178 %{_mandir}/man1/dpkg-gencontrol.1.gz
179 %{_mandir}/man1/dpkg-gensymbols.1.gz
180 %{_mandir}/man1/dpkg-name.1.gz
181 %{_mandir}/man1/dpkg-parsechangelog.1.gz
182 %{_mandir}/man1/dpkg-scanpackages.1.gz
183 %{_mandir}/man1/dpkg-scansources.1.gz
184 %{_mandir}/man1/dpkg-shlibdeps.1.gz
185 %{_mandir}/man1/dpkg-source.1.gz
186 %{_mandir}/man1/dpkg-vendor.1.gz
187 %{_mandir}/man5/deb-control.5.gz
188 %{_mandir}/man5/deb-old.5.gz
189 %{_mandir}/man5/deb-override.5.gz
190 %{_mandir}/man5/deb-extra-override.5.gz
191 %{_mandir}/man5/deb-shlibs.5.gz
192 %{_mandir}/man5/deb-substvars.5.gz
193 %{_mandir}/man5/deb-symbols.5.gz
194 %{_mandir}/man5/deb-triggers.5.gz
195 %{_mandir}/man5/deb-version.5.gz
196 %{_mandir}/man5/deb.5.gz
197
198
199 %files -n dselect -f dselect.lang
200 %defattr(-,root,root,-)
201 %doc dselect/methods/multicd/README.multicd dselect/methods/ftp/README.mirrors.txt
202 %{_bindir}/dselect
203 %{perl_vendorlib}/Debian
204 %{_datadir}/dpkg/methods
205 %{_mandir}/man*/dselect*.gz
206
207
208
209 %changelog
210 * Wed Jan 12 2011 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-6
211 - Fix CVE-2010-1679
212 - Fix CVE-2011-0402
213
214 * Sun Oct 17 2010 Jeroen van Meeuwen <kanarip@kanarip.com> - 1.15.5.6-5
215 - Apply minimal fix for rhbz #642160
216
217 * Thu Mar 11 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-4
218 - Fix CVE-2010-0396
219
220 * Mon Feb 15 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-3
221 - review changes
222
223 * Sun Feb 14 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-2
224 - review changes
225
226 * Sat Feb 13 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-1
227 - Upgrade to latest upstream
228 - review changes
229
230 * Tue Nov 10 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.4.1-1
231 - Upgrade to latest upstream
232 - review changes
233
234 * Tue Dec 30 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.23-3
235 - more review changes               
236
237 * Mon Dec 15 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.23-1
238 - bump version and make some of the review changes
239
240 * Tue Aug 19 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-5
241 - made changes for review 
242
243 * Thu Jul 31 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-4
244 - Change release to -4 as server refused -3
245
246 * Thu Jul 31 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-3
247 - split the package into dkpg, dpkg-dev & dselect
248
249 * Tue Jul 29 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-2
250 - recode man files to UTF8
251
252 * Tue Jul 29 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-1
253 - Rebuild ans add build requires ncurses-devel
254
255 * Thu Jul 19 2007 Patrice Dumas <pertusus@free.fr> - 1.14.5-1
256 - initial packaging