Fix pbr and prettytable version for ceilometer client
[openstack-build/python-ceilometerclient-build.git] / rpm / SPECS / python-ceilometerclient.spec
1 Name:             python-ceilometerclient
2 Version:          1.0.10
3 Release:          3%{?dist}
4 Summary:          Python API and CLI for OpenStack Ceilometer
5
6 Group:            Development/Languages
7 License:          ASL 2.0
8 URL:              https://github.com/openstack/%{name}
9 Source0:          https://pypi.python.org/packages/source/p/%{name}/%{name}-%{version}.tar.gz
10
11 BuildArch:        noarch
12 BuildRequires:    python-setuptools
13 BuildRequires:    python2-devel
14 BuildRequires:    python-pbr
15 BuildRequires:    python-d2to1
16
17 Requires:         python-setuptools
18 Requires:         python-argparse
19 Requires:         python-prettytable >= 0.7, python-prettytable < 0.8
20 Requires:         python-iso8601
21 Requires:         python-pbr >= 0.6, python-pbr < 0.7, python-pbr > 0.7, python-pbr < 1.0
22 Requires:         python-keystoneclient
23 Requires:         python-six >= 1.5.2
24
25 #
26 # patches_base=1.0.10
27 #
28 Patch0001: 0001-Remove-runtime-dependency-on-python-pbr.patch
29
30 %description
31 This is a client library for Ceilometer built on the Ceilometer API. It
32 provides a Python API (the ceilometerclient module) and a command-line tool
33 (ceilometer).
34
35
36 %package doc
37 Summary:          Documentation for OpenStack Ceilometer API Client
38 Group:            Documentation
39
40 BuildRequires:    python-sphinx
41
42 %description      doc
43 This is a client library for Ceilometer built on the Ceilometer API. It
44 provides a Python API (the ceilometerclient module) and a command-line tool
45 (ceilometer).
46
47 This package contains auto-generated documentation.
48
49
50 %prep
51 %setup -q
52
53 %patch0001 -p1
54
55 # We provide version like this in order to remove runtime dep on pbr.
56 sed -i s/REDHATCEILOMETERCLIENTVERSION/%{version}/ ceilometerclient/__init__.py
57
58 # Remove bundled egg-info
59 rm -rf python_ceilometerclient.egg-info
60
61 # Let RPM handle the requirements
62 rm -f {,test-}requirements.txt
63
64 %build
65 %{__python} setup.py build
66
67 %install
68 %{__python} setup.py install -O1 --skip-build --root %{buildroot}
69
70 export PYTHONPATH="$( pwd ):$PYTHONPATH"
71 sphinx-build -b html doc/source html
72
73 # Fix hidden-file-or-dir warnings
74 rm -rf html/.doctrees html/.buildinfo
75
76 %files
77 %doc README.rst
78 %doc LICENSE
79 %{_bindir}/ceilometer
80 %{python_sitelib}/ceilometerclient
81 %{python_sitelib}/*.egg-info
82
83 %files doc
84 %doc html
85
86 %changelog
87 * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.10-2
88 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
89
90 * Thu Jun 05 2014 Jakub Ruzicka <jruzicka@redhat.com> 1.0.10-1
91 - Update to upstream 1.0.10
92 - Remove requirements.txt in .spec instead of patch
93
94 * Mon Feb 17 2014 Pádraig Brady <pbrady@redhat.com> - 1.0.9-3
95 - Require python-six >= 1.4.1 to ensure update
96
97 * Mon Feb 17 2014 Alan Pevec <apevec@redhat.com> 1.0.9-1
98 - Update to upstream 1.0.9
99
100 * Mon Dec 16 2013 Jakub Ruzicka <jruzicka@redhat.com> 1.0.8-1
101 - Update to upstream 1.0.8
102 - New dependency: python-six
103
104 * Mon Oct 07 2013 Jakub Ruzicka <jruzicka@redhat.com> 1.0.6-1
105 - Update to upstream 1.0.6.
106
107 * Mon Sep 09 2013 Jakub Ruzicka <jruzicka@redhat.com> 1.0.3-1
108 - Update to upstream 1.0.3.
109 - README extension changed.
110 - Get rid of pbr deps in the patch instead of this spec file.
111
112 * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-3
113 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
114
115 * Tue Jul 16 2013 Jakub Ruzicka <jruzicka@redhat.com> 1.0.1-2
116 - New build requires: python-d2to1, python-pbr.
117
118 * Tue Jul 16 2013 Jakub Ruzicka <jruzicka@redhat.com> 1.0.1-1
119 - Update to upstream version 1.0.1.
120 - Remove new runtime dependency on python-pbr.
121 - Remove requirements file.
122 - Make requires generic instead of requiring specific versions.
123
124 * Mon Apr 01 2013 Jakub Ruzicka <jruzicka@redhat.com> 1.0.0
125 - Update to upstream version 1.0.0.
126 - Added Requires: python-keystoneclient >= 0.1.2.
127
128 * Tue Mar 26 2013 Jakub Ruzicka <jruzicka@redhat.com> 0.0.10-0.2.gitd84fd99
129 - Add BuildRequires: python2-devel.
130
131 * Tue Mar 26 2013 Jakub Ruzicka <jruzicka@redhat.com> 0.0.10-0.1.gitd84fd99
132 - Initial package based on python-novaclient.