The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / support / kconfig / patches / 15-fix-qconf-moc-rule.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/support/kconfig/patches/15-fix-qconf-moc-rule.patch b/cirros-testvm/src-cirros/buildroot-2015.05/support/kconfig/patches/15-fix-qconf-moc-rule.patch
new file mode 100644 (file)
index 0000000..c1848d7
--- /dev/null
@@ -0,0 +1,24 @@
+Fix the rule that generates the .moc file
+
+The Linux kernel has a "cmd" make function, but we don't have it in
+Buildroot, so we need to adjust this rule.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -309,11 +309,8 @@
+ $(obj)/qconf.o: $(obj)/qconf.moc
+-quiet_cmd_moc = MOC     $@
+-      cmd_moc = $(KC_QT_MOC) -i $< -o $@
+-
+ $(obj)/%.moc: $(src)/%.h $(obj)/.tmp_qtcheck
+-      $(call cmd,moc)
++      $(KC_QT_MOC) -i $< -o $@
+ # Extract gconf menu items for I18N support
+ $(obj)/gconf.glade.h: $(obj)/gconf.glade