The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / zsh / zsh.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/zsh/zsh.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/zsh/zsh.mk
new file mode 100644 (file)
index 0000000..ffc567d
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# zsh
+#
+################################################################################
+
+ZSH_VERSION = 5.0.7
+ZSH_SITE = http://www.zsh.org/pub
+ZSH_DEPENDENCIES = ncurses
+ZSH_CONF_OPTS = --bindir=/bin
+ZSH_LICENSE = MIT-like
+ZSH_LICENSE_FILES = LICENCE
+
+# Remove versioned zsh-x.y.z binary taking up space
+define ZSH_TARGET_INSTALL_FIXUPS
+       rm -f $(TARGET_DIR)/bin/zsh-$(ZSH_VERSION)
+endef
+ZSH_POST_INSTALL_TARGET_HOOKS += ZSH_TARGET_INSTALL_FIXUPS
+
+$(eval $(autotools-package))