The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / zeromq / zeromq.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/zeromq/zeromq.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/zeromq/zeromq.mk
new file mode 100644 (file)
index 0000000..7e9ed19
--- /dev/null
@@ -0,0 +1,37 @@
+################################################################################
+#
+# zeromq
+#
+################################################################################
+
+ZEROMQ_VERSION = 4.0.5
+ZEROMQ_SITE = http://download.zeromq.org
+ZEROMQ_INSTALL_STAGING = YES
+ZEROMQ_DEPENDENCIES = util-linux
+ZEROMQ_LICENSE = LGPLv3+ with exceptions
+ZEROMQ_LICENSE_FILES = COPYING COPYING.LESSER
+# For 0001-tests-disable-test_fork-if-fork-is-not-available.patch
+# and 0002-acinclude.m4-make-kernel-specific-flags-cacheable.patch
+ZEROMQ_AUTORECONF = YES
+
+# Assume these flags are always available. It is true, at least for
+# SOCK_CLOEXEC, since linux v2.6.27.
+# Note: the flag TCP_KEEPALIVE is NOT available so we do not include it.
+ZEROMQ_CONF_ENV = libzmq_cv_sock_cloexec=yes \
+       libzmq_cv_so_keepalive=yes \
+       libzmq_cv_tcp_keepcnt=yes \
+       libzmq_cv_tcp_keepidle=yes \
+       libzmq_cv_tcp_keepintvl=yes
+
+# Only tools/curve_keygen.c needs this, but it doesn't hurt to pass it
+# for the rest of the build as well (which automatically includes stdc++).
+ifeq ($(BR2_STATIC_LIBS),y)
+ZEROMQ_CONF_OPTS += LIBS=-lstdc++
+endif
+
+ifeq ($(BR2_PACKAGE_ZEROMQ_PGM),y)
+ZEROMQ_DEPENDENCIES += host-pkgconf openpgm
+ZEROMQ_CONF_OPTS += --with-system-pgm
+endif
+
+$(eval $(autotools-package))