The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / zeromq / 0001-tests-disable-test_fork-if-fork-is-not-available.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/zeromq/0001-tests-disable-test_fork-if-fork-is-not-available.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/zeromq/0001-tests-disable-test_fork-if-fork-is-not-available.patch
new file mode 100644 (file)
index 0000000..1eefdc3
--- /dev/null
@@ -0,0 +1,52 @@
+From b50912f2eecec1ea7accc155f8132116f8702075 Mon Sep 17 00:00:00 2001
+From: Samuel Martin <s.martin49@gmail.com>
+Date: Sat, 3 May 2014 12:22:38 +0200
+Subject: [PATCH] tests: disable test_fork if fork() is not available
+
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+---
+ configure.ac      | 1 +
+ tests/Makefile.am | 8 ++++++--
+ tests/Makefile.in | 8 ++++----
+ 3 files changed, 11 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0c41604..8f8521c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -431,6 +431,7 @@ AM_CONDITIONAL(BUILD_PGM, test "x$libzmq_pgm_ext" = "xyes")
+ AM_CONDITIONAL(ON_MINGW, test "x$libzmq_on_mingw32" = "xyes")
+ AM_CONDITIONAL(ON_ANDROID, test "x$libzmq_on_android" = "xyes")
+ AM_CONDITIONAL(ON_LINUX, test "x$libzmq_on_linux" = "xyes")
++AM_CONDITIONAL(HAVE_FORK, test "x$ac_cv_func_fork" = "xyes")
+ # Checks for library functions.
+ AC_TYPE_SIGNAL
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 0cfe4e8..2a1e257 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -46,8 +46,10 @@ if !ON_MINGW
+ noinst_PROGRAMS += test_shutdown_stress \
+                    test_pair_ipc \
+                    test_reqrep_ipc \
+-                   test_timeo \
+-                   test_fork
++                   test_timeo
++if HAVE_FORK
++noinst_PROGRAMS += test_fork
++endif
+ endif
+ test_system_SOURCES = test_system.cpp
+@@ -93,8 +95,10 @@ test_shutdown_stress_SOURCES = test_shutdown_stress.cpp
+ test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
+ test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
+ test_timeo_SOURCES = test_timeo.cpp
++if HAVE_FORK
+ test_fork_SOURCES = test_fork.cpp
+ endif
++endif
+ #  Run the test cases
+ TESTS = $(noinst_PROGRAMS)