The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / xz / xz.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/xz/xz.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/xz/xz.mk
new file mode 100644 (file)
index 0000000..503275c
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# xz
+#
+################################################################################
+
+XZ_VERSION = 5.2.1
+XZ_SOURCE = xz-$(XZ_VERSION).tar.bz2
+XZ_SITE = http://tukaani.org/xz
+XZ_INSTALL_STAGING = YES
+XZ_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
+XZ_LICENSE = GPLv2+ GPLv3+ LGPLv2.1+
+XZ_LICENSE_FILES = COPYING.GPLv2 COPYING.GPLv3 COPYING.LGPLv2.1
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+XZ_CONF_OPTS = --enable-threads
+else
+XZ_CONF_OPTS = --disable-threads
+endif
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))