The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / xscreensaver / xscreensaver.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/xscreensaver/xscreensaver.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/xscreensaver/xscreensaver.mk
new file mode 100644 (file)
index 0000000..c78c8ce
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# xscreensaver
+#
+################################################################################
+
+XSCREENSAVER_VERSION = 5.22
+XSCREENSAVER_SITE = http://www.jwz.org/xscreensaver
+
+# N.B. GPLv2+ code (in the hacks/glx subdirectory) is not currently built.
+XSCREENSAVER_LICENSE = MIT-like GPLv2+
+XSCREENSAVER_LICENSE_FILES = hacks/screenhack.h hacks/glx/chessmodels.h
+
+XSCREENSAVER_DEPENDENCIES = jpeg libglade libgtk2 xlib_libX11 xlib_libXt \
+       $(if $(BR2_PACKAGE_GETTEXT),gettext)
+
+# otherwise we end up with host include/library dirs passed to the
+# compiler/linker
+XSCREENSAVER_CONF_OPTS = \
+       --includedir=$(STAGING_DIR)/usr/include \
+       --libdir=$(STAGING_DIR)/usr/lib
+
+XSCREENSAVER_INSTALL_TARGET_OPTS = install_prefix="$(TARGET_DIR)" install
+
+$(eval $(autotools-package))