The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / xinetd / xinetd.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/xinetd/xinetd.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/xinetd/xinetd.mk
new file mode 100644 (file)
index 0000000..92d0d53
--- /dev/null
@@ -0,0 +1,33 @@
+################################################################################
+#
+# xinetd
+#
+################################################################################
+
+XINETD_VERSION = xinetd-2-3-15
+XINETD_SITE = $(call github,xinetd-org,xinetd,$(XINETD_VERSION))
+XINETD_LICENSE = xinetd license
+XINETD_LICENSE_FILES = COPYRIGHT
+
+XINETD_CFLAGS = $(TARGET_CFLAGS)
+
+# Three cases here:
+#  1. We have libtirpc, use it by passing special flags
+#  2. We have native RPC support, use it, no need to pass special
+#     flags (so this case 2 is implicit and not visible below)
+#  3. We don't have RPC support, pass -DNO_RPC to disable it
+ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
+XINETD_DEPENDENCIES += libtirpc
+XINETD_CFLAGS += -I$(STAGING_DIR)/usr/include/tirpc/
+XINETD_LIBS += -ltirpc
+else ifeq ($(BR2_TOOLCHAIN_HAS_NATIVE_RPC),)
+XINETD_CFLAGS += -DNO_RPC
+endif
+
+XINETD_CONF_ENV += \
+       CFLAGS="$(XINETD_CFLAGS)" \
+       LIBS="$(XINETD_LIBS)"
+
+XINETD_MAKE_OPTS = AR="$(TARGET_AR)"
+
+$(eval $(autotools-package))