The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / x11r7 / mcookie / mcookie.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/x11r7/mcookie/mcookie.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/x11r7/mcookie/mcookie.mk
new file mode 100644 (file)
index 0000000..87a236f
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# mcookie
+#
+################################################################################
+
+# Source included in Buildroot
+MCOOKIE_SOURCE =
+MCOOKIE_LICENSE = Public Domain
+
+define MCOOKIE_EXTRACT_CMDS
+       cp package/x11r7/mcookie/mcookie.c $(@D)/
+endef
+
+define MCOOKIE_BUILD_CMDS
+       (cd $(@D); $(TARGET_CC) -Wall -Os -s mcookie.c -o mcookie)
+endef
+
+define MCOOKIE_INSTALL_TARGET_CMDS
+       install -m 0755 -D $(@D)/mcookie $(TARGET_DIR)/usr/bin/mcookie
+endef
+
+$(eval $(generic-package))