The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / x11r7 / libxcb / libxcb.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/x11r7/libxcb/libxcb.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/x11r7/libxcb/libxcb.mk
new file mode 100644 (file)
index 0000000..f4a3aa9
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libxcb
+#
+################################################################################
+
+LIBXCB_VERSION = 1.11
+LIBXCB_SOURCE = libxcb-$(LIBXCB_VERSION).tar.bz2
+LIBXCB_SITE = http://xcb.freedesktop.org/dist
+LIBXCB_LICENSE = MIT
+LIBXCB_LICENSE_FILES = COPYING
+
+LIBXCB_INSTALL_STAGING = YES
+
+LIBXCB_DEPENDENCIES = \
+       host-libxslt libpthread-stubs xcb-proto xlib_libXdmcp xlib_libXau \
+       host-xcb-proto host-python host-pkgconf
+
+LIBXCB_CONF_OPTS = --with-doxygen=no
+HOST_LIBXCB_CONF_OPTS = --with-doxygen=no
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))