The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / wvstreams / wvstreams.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/wvstreams/wvstreams.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/wvstreams/wvstreams.mk
new file mode 100644 (file)
index 0000000..4d344e2
--- /dev/null
@@ -0,0 +1,62 @@
+################################################################################
+#
+# wvstreams
+#
+################################################################################
+
+WVSTREAMS_VERSION = 4.6.1
+WVSTREAMS_SITE = http://wvstreams.googlecode.com/files
+WVSTREAMS_DEPENDENCIES = openssl zlib host-pkgconf
+WVSTREAMS_INSTALL_STAGING = YES
+
+WVSTREAMS_LICENSE = LGPLv2+
+WVSTREAMS_LICENSE_FILES = LICENSE
+
+# N.B. parallel make fails
+WVSTREAMS_MAKE = $(MAKE1)
+
+# Needed to work around problem with wvassert.h
+WVSTREAMS_CONF_OPTS += CPPFLAGS=-DNDEBUG
+
+WVSTREAMS_CONF_OPTS += \
+       --with-openssl \
+       --with-zlib \
+       --without-pam \
+       --disable-warnings \
+       --without-tcl
+
+# needed for openssl detection when statically linking (as ssl needs lz)
+WVSTREAMS_CONF_ENV += LIBS=-lz
+
+ifneq ($(BR2_STATIC_LIBS),y)
+WVSTREAMS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
+endif
+
+# wvstreams uses argp.h which can be provided by the argp-standalone
+# package
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
+WVSTREAMS_DEPENDENCIES += argp-standalone
+endif
+
+ifeq ($(BR2_PACKAGE_DBUS),y)
+WVSTREAMS_DEPENDENCIES += dbus
+WVSTREAMS_CONF_OPTS += --with-dbus
+else
+WVSTREAMS_CONF_OPTS += --without-dbus
+endif
+
+ifeq ($(BR2_PACKAGE_QT),y)
+WVSTREAMS_DEPENDENCIES += qt
+WVSTREAMS_CONF_OPTS += --with-qt
+else
+WVSTREAMS_CONF_OPTS += --without-qt
+endif
+
+ifeq ($(BR2_PACKAGE_VALGRIND),y)
+WVSTREAMS_DEPENDENCIES += valgrind
+WVSTREAMS_CONF_OPTS += --with-valgrind
+else
+WVSTREAMS_CONF_OPTS += --without-valgrind
+endif
+
+$(eval $(autotools-package))