The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / wireless-regdb / wireless-regdb.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/wireless-regdb/wireless-regdb.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/wireless-regdb/wireless-regdb.mk
new file mode 100644 (file)
index 0000000..20b330f
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# wireless-regdb
+#
+################################################################################
+
+WIRELESS_REGDB_VERSION = 2015.04.06
+WIRELESS_REGDB_SOURCE = wireless-regdb-$(WIRELESS_REGDB_VERSION).tar.xz
+WIRELESS_REGDB_SITE = http://kernel.org/pub/software/network/wireless-regdb
+WIRELESS_REGDB_LICENSE = ISC
+WIRELESS_REGDB_LICENSE_FILES = LICENSE
+
+define WIRELESS_REGDB_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 644 -D -T $(@D)/regulatory.bin \
+               $(TARGET_DIR)/usr/lib/crda/regulatory.bin
+       $(INSTALL) -m 644 -D -T $(@D)/sforshee.key.pub.pem \
+               $(TARGET_DIR)/etc/wireless-regdb/pubkeys/sforshee.key.pub.pem
+endef
+
+$(eval $(generic-package))