The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / whetstone / whetstone.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/whetstone/whetstone.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/whetstone/whetstone.mk
new file mode 100644 (file)
index 0000000..d9b4563
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# whetstone
+#
+################################################################################
+
+WHETSTONE_VERSION = 1.2
+WHETSTONE_SOURCE = whetstone.c
+WHETSTONE_SITE = http://www.netlib.org/benchmark
+
+define WHETSTONE_EXTRACT_CMDS
+       cp $(DL_DIR)/$($(PKG)_SOURCE) $(@D)/
+endef
+
+define WHETSTONE_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) LDLIBS="-lm" -C $(@D) whetstone
+endef
+
+define WHETSTONE_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/whetstone $(TARGET_DIR)/usr/bin/whetstone
+endef
+
+$(eval $(generic-package))