The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / wf111 / Config.in
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/wf111/Config.in b/cirros-testvm/src-cirros/buildroot-2015.05/package/wf111/Config.in
new file mode 100644 (file)
index 0000000..d2ba440
--- /dev/null
@@ -0,0 +1,36 @@
+config BR2_PACKAGE_WF111
+       bool "wf111"
+       depends on BR2_LINUX_KERNEL
+       depends on BR2_ARM_CPU_ARMV5 || BR2_ARM_CPU_ARMV7A || BR2_i386
+       # Binary tools are distributed alongside the driver, and are
+       # dynamically linked against the glibc.
+       depends on BR2_TOOLCHAIN_USES_GLIBC
+       help
+         BlueGiga WF111 WiFi driver and utilities.
+
+         Warning: CONFIG_WIRELESS_EXT and CONFIG_WEXT_PRIV must be
+         selected in the Linux kernel configuration. These are blind
+         options (i.e. not selectable directly) so they cannot be
+         enabled by a change in linux/linux.mk. There are two choices
+         to enable these options:
+         - By making them non blind, with a "WF111 support" configuration
+           entry that selects them, for example.
+         - By enabling another random WiFi driver that select them.
+
+         http://www.bluegiga.com/en-US/products/wifi-modules/wf111-wifi-module/
+
+if BR2_PACKAGE_WF111
+
+config BR2_PACKAGE_WF111_TARBALL_PATH
+       string "Local tarball location"
+       help
+         The WF111 tarball can be retrieved on the BlueGiga website
+         after registration. This option specifies the path where the
+         tarball is locally saved.
+
+endif
+
+comment "wf111 needs an (e)glibc toolchain"
+       depends on BR2_LINUX_KERNEL
+       depends on BR2_ARM_CPU_ARMV5 || BR2_ARM_CPU_ARMV7A || BR2_i386
+       depends on !BR2_TOOLCHAIN_USES_GLIBC