The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / weston / weston.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/weston/weston.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/weston/weston.mk
new file mode 100644 (file)
index 0000000..bf49436
--- /dev/null
@@ -0,0 +1,59 @@
+################################################################################
+#
+# weston
+#
+################################################################################
+
+WESTON_VERSION = 1.7.0
+WESTON_SITE = http://wayland.freedesktop.org/releases
+WESTON_SOURCE = weston-$(WESTON_VERSION).tar.xz
+WESTON_LICENSE = MIT
+WESTON_LICENSE_FILES = COPYING
+
+WESTON_DEPENDENCIES = host-pkgconf wayland libxkbcommon pixman libpng \
+       jpeg mtdev udev cairo libinput
+
+WESTON_CONF_OPTS = \
+       --with-dtddir=$(STAGING_DIR)/usr/share/wayland \
+       --disable-egl \
+       --disable-simple-egl-clients \
+       --disable-xwayland \
+       --disable-x11-compositor \
+       --disable-drm-compositor \
+       --disable-wayland-compositor \
+       --disable-headless-compositor \
+       --disable-weston-launch \
+       --disable-colord
+
+ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
+WESTON_DEPENDENCIES += libunwind
+else
+WESTON_CONF_OPTS += --disable-libunwind
+endif
+
+ifeq ($(BR2_PACKAGE_WESTON_RDP),y)
+WESTON_DEPENDENCIES += freerdp
+WESTON_CONF_OPTS += --enable-rdp-compositor
+else
+WESTON_CONF_OPTS += --disable-rdp-compositor
+endif
+
+ifeq ($(BR2_PACKAGE_WESTON_FBDEV),y)
+WESTON_CONF_OPTS += --enable-fbdev-compositor
+else
+WESTON_CONF_OPTS += --disable-fbdev-compositor
+endif
+
+ifeq ($(BR2_PACKAGE_WESTON_RPI),y)
+WESTON_DEPENDENCIES += rpi-userland
+WESTON_CONF_OPTS += --enable-rpi-compositor \
+       --disable-resize-optimization \
+       --disable-setuid-install \
+       --disable-xwayland-test \
+       --disable-simple-egl-clients \
+       WESTON_NATIVE_BACKEND=rpi-backend.so
+else
+WESTON_CONF_OPTS += --disable-rpi-compositor
+endif # BR2_PACKAGE_WESTON_RPI
+
+$(eval $(autotools-package))