The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / webp / webp.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/webp/webp.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/webp/webp.mk
new file mode 100644 (file)
index 0000000..5f2cab7
--- /dev/null
@@ -0,0 +1,30 @@
+################################################################################
+#
+# webp
+#
+################################################################################
+
+WEBP_VERSION = 0.4.3
+WEBP_SOURCE = libwebp-$(WEBP_VERSION).tar.gz
+WEBP_SITE = http://downloads.webmproject.org/releases/webp
+WEBP_LICENSE = BSD-3c
+WEBP_LICENSE_FILES = COPYING
+WEBP_INSTALL_STAGING = YES
+
+WEBP_CONF_OPTS += \
+       --with-jpegincludedir=$(STAGING_DIR)/usr/include \
+       --with-jpeglibdir=$(STAGING_DIR)/usr/lib \
+       --with-tiffincludedir=$(STAGING_DIR)/usr/include \
+       --with-tifflibdir=$(STAGING_DIR)/usr/lib
+
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+WEBP_DEPENDENCIES += libpng
+WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
+else
+WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=/bin/false
+endif
+
+WEBP_DEPENDENCIES += $(if $(BR2_PACKAGE_JPEG),jpeg)
+WEBP_DEPENDENCIES += $(if $(BR2_PACKAGE_TIFF),tiff)
+
+$(eval $(autotools-package))