The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / vorbis-tools / vorbis-tools.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/vorbis-tools/vorbis-tools.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/vorbis-tools/vorbis-tools.mk
new file mode 100644 (file)
index 0000000..fc8e7dd
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# vorbis-tools
+#
+################################################################################
+
+VORBIS_TOOLS_VERSION = 1.4.0
+VORBIS_TOOLS_SITE = http://downloads.xiph.org/releases/vorbis
+VORBIS_TOOLS_LICENSE = GPLv2
+VORBIS_TOOLS_LICENSE_FILES = COPYING
+VORBIS_TOOLS_DEPENDENCIES = libao libogg libvorbis libcurl
+VORBIS_TOOLS_CONF_OPTS = --program-transform-name=''
+# ogg123 calls math functions but forgets to link with libm
+VORBIS_TOOLS_CONF_ENV = LIBS=-lm
+
+ifeq ($(BR2_PACKAGE_FLAC),y)
+VORBIS_TOOLS_DEPENDENCIES += flac
+endif
+
+ifeq ($(BR2_PACKAGE_SPEEX),y)
+VORBIS_TOOLS_DEPENDENCIES += speex
+endif
+
+$(eval $(autotools-package))