The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / vlc / 0002-configure.ac-add-check-for-libgcrypt-config-program.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/vlc/0002-configure.ac-add-check-for-libgcrypt-config-program.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/vlc/0002-configure.ac-add-check-for-libgcrypt-config-program.patch
new file mode 100644 (file)
index 0000000..e9a7315
--- /dev/null
@@ -0,0 +1,43 @@
+From 88bf3313850bc7f0e6db21daee2b8d8e607b7bb4 Mon Sep 17 00:00:00 2001
+From: Samuel Martin <s.martin49@gmail.com>
+Date: Sat, 8 Feb 2014 14:33:27 +0100
+Subject: [PATCH] configure.ac: add check for libgcrypt-config program
+
+This allows to override the default libgcrypt-config location (which is
+useful when cross-compiling), instead of using the one from the host
+system.
+
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+[yann.morin.1998@free.fr: adapt from 2.1.6 to 2.2.0; fix quoting in
+ AC_PATH_PROG]
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+---
+ configure.ac | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 02fb8aa..5a2267b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -4020,16 +4020,17 @@
+ AC_ARG_ENABLE(libgcrypt,
+   [  --disable-libgcrypt     gcrypt support (default enabled)])
+ AS_IF([test "${enable_libgcrypt}" != "no"], [
++  AC_PATH_PROG([GCRYPT_CONFIG],[libgcrypt-config],[libgcrypt-config])
+   AC_CHECK_DECL([GCRYCTL_SET_THREAD_CBS], [
+-    libgcrypt-config --version >/dev/null || \
++    ${GCRYPT_CONFIG} --version >/dev/null || \
+         AC_MSG_ERROR([gcrypt.h present but libgcrypt-config could not be found])
+     AC_CHECK_LIB(gcrypt, gcry_control, [
+       have_libgcrypt="yes"
+-      GCRYPT_CFLAGS="`libgcrypt-config --cflags`"
+-      GCRYPT_LIBS="`libgcrypt-config --libs`"
++      GCRYPT_CFLAGS="`${GCRYPT_CONFIG} --cflags`"
++      GCRYPT_LIBS="`${GCRYPT_CONFIG} --libs`"
+     ], [
+       AC_MSG_ERROR([libgcrypt not found. Install libgcrypt or pass --disable-libgcrypt.])
+-    ], [`libgcrypt-config --libs`])
++    ], [`${GCRYPT_CONFIG} --libs`])
+   ], [
+     AC_MSG_ERROR([libgcrypt version 1.1.94 or higher not found. Install libgcrypt or pass --disable-libgcrypt.])
+   ], [#include <gcrypt.h>]