The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / usbutils / usbutils.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/usbutils/usbutils.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/usbutils/usbutils.mk
new file mode 100644 (file)
index 0000000..c96a1f5
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# usbutils
+#
+################################################################################
+
+USBUTILS_VERSION = 008
+USBUTILS_SOURCE = usbutils-$(USBUTILS_VERSION).tar.xz
+USBUTILS_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/usb/usbutils
+USBUTILS_DEPENDENCIES = host-pkgconf libusb udev
+USBUTILS_LICENSE = GPLv2+
+USBUTILS_LICENSE_FILES = COPYING
+
+# Build after busybox since it's got a lightweight lsusb
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+USBUTILS_DEPENDENCIES += busybox
+endif
+
+# Nice lsusb.py script only if there's python
+ifeq ($(BR2_PACKAGE_PYTHON),)
+define USBUTILS_REMOVE_PYTHON
+       rm -f $(TARGET_DIR)/usr/bin/lsusb.py
+endef
+
+USBUTILS_POST_INSTALL_TARGET_HOOKS += USBUTILS_REMOVE_PYTHON
+endif
+
+define USBUTILS_TARGET_CLEANUP
+       rm -f $(TARGET_DIR)/usr/bin/usb-devices
+endef
+
+USBUTILS_POST_INSTALL_TARGET_HOOKS += USBUTILS_TARGET_CLEANUP
+
+$(eval $(autotools-package))