The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / unionfs / 0001-fuse-no-cxx-needed.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/unionfs/0001-fuse-no-cxx-needed.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/unionfs/0001-fuse-no-cxx-needed.patch
new file mode 100644 (file)
index 0000000..56f7e24
--- /dev/null
@@ -0,0 +1,19 @@
+By default, CMake assumes a project uses the C and C++ languages, so
+it checks for both the C and the C++ compiler to exist.
+
+However, unionfs-fuse is written purely in C, so checking for a C++
+compiler is useless, and even prevents unionfs-fuse from building
+properly on targets for which no C++ compiler is available.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-project(unionfs-fuse)
++project(unionfs-fuse C)
+ cmake_minimum_required(VERSION 2.0)
+ INCLUDE (CheckIncludeFiles)