The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / uemacs / uemacs.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/uemacs/uemacs.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/uemacs/uemacs.mk
new file mode 100644 (file)
index 0000000..19fda12
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# uemacs
+#
+################################################################################
+
+UEMACS_VERSION = 8841922689769960fa074fbb053cb8507f2f3ed9
+UEMACS_SITE = $(BR2_KERNEL_MIRROR)/scm/editors/uemacs/uemacs.git
+UEMACS_SITE_METHOD = git
+UEMACS_DEPENDENCIES = ncurses
+
+define UEMACS_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               CC="$(TARGET_CC)" DEFINES="-DAUTOCONF -DPOSIX -DUSG" \
+               CFLAGS+="$(TARGET_CFLAGS) " LIBS="$(TARGET_CFLAGS) -lncurses"
+endef
+
+define UEMACS_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/em $(TARGET_DIR)/usr/bin/em
+endef
+
+$(eval $(generic-package))