The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / udisks / udisks.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/udisks/udisks.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/udisks/udisks.mk
new file mode 100644 (file)
index 0000000..7a24106
--- /dev/null
@@ -0,0 +1,29 @@
+################################################################################
+#
+# udisks
+#
+################################################################################
+
+UDISKS_VERSION = 1.0.4
+UDISKS_SITE = http://hal.freedesktop.org/releases
+UDISKS_LICENSE = GPLv2+
+UDISKS_LICENSE_FILES = COPYING
+
+UDISKS_DEPENDENCIES =  \
+       sg3_utils       \
+       host-pkgconf    \
+       udev            \
+       dbus            \
+       dbus-glib       \
+       polkit          \
+       parted          \
+       lvm2            \
+       libatasmart
+
+UDISKS_CONF_OPTS = --disable-remote-access --disable-man-pages
+
+ifeq ($(BR2_PACKAGE_UDISKS_LVM2),y)
+UDISKS_CONF_OPTS += --enable-lvm2
+endif
+
+$(eval $(autotools-package))