The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / tstools / tstools.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/tstools/tstools.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/tstools/tstools.mk
new file mode 100644 (file)
index 0000000..40920d2
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# tstools
+#
+################################################################################
+
+TSTOOLS_VERSION = 1_11
+TSTOOLS_SITE = https://tstools.googlecode.com/files
+TSTOOLS_SOURCE = tstools-$(TSTOOLS_VERSION).tgz
+TSTOOLS_LICENSE = MPL v1.1
+
+define TSTOOLS_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) LD="$(TARGET_CC)" $(TARGET_MAKE_ENV) \
+               $(MAKE1) -C $(@D)
+endef
+
+define TSTOOLS_INSTALL_TARGET_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))