The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / tstools / 001-build-get-along-with-buildroot.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/tstools/001-build-get-along-with-buildroot.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/tstools/001-build-get-along-with-buildroot.patch
new file mode 100644 (file)
index 0000000..1e7a748
--- /dev/null
@@ -0,0 +1,40 @@
+From 44f80bce0914d4d9c5e7486c7cdb521ba637b324 Mon Sep 17 00:00:00 2001
+From: Tzu-Jung Lee <tjlee@ambarella.com>
+Date: Fri, 19 Jul 2013 22:45:18 +0800
+Subject: [PATCH] build: get along with buildroot
+
+Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
+---
+ Makefile | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2c3568e..98bb994 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,12 +34,6 @@ SHELL = /bin/sh
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+-ifdef CROSS_COMPILE
+-CC = $(CROSS_COMPILE)gcc
+-else
+-CC = gcc
+-endif
+-
+ # Use WARN=1 periodically to get too many warnings...
+ ifdef WARN
+ WARNING_FLAGS = -Wall -W -Wfloat-equal -Wundef -Wshadow -Wpointer-arith -Wcast-qual -Wconversion -Wmissing-prototypes -Wmissing-declarations -Wunreachable-code -Winline
+@@ -452,3 +446,9 @@ test_lists:        $(BINDIR)/test_nal_unit_list  $(BINDIR)/test_es_unit_list
+       @echo +++ Testing ES unit lists
+       $(BINDIR)/test_es_unit_list
+       @echo +++ Test succeeded
++
++.PHONY: install
++install:
++      @for i in $(PROGS); do \
++              cp -f $$i $(DESTDIR)/usr/bin/; \
++      done
+-- 
+1.8.3.2
+