The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / tremor / tremor.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/tremor/tremor.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/tremor/tremor.mk
new file mode 100644 (file)
index 0000000..590a18c
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# tremor
+#
+################################################################################
+
+TREMOR_SITE = http://svn.xiph.org/trunk/Tremor
+TREMOR_SITE_METHOD = svn
+TREMOR_VERSION = 18153
+TREMOR_LICENSE = BSD-3c
+TREMOR_LICENSE_FILES = COPYING
+
+TREMOR_AUTORECONF = YES
+TREMOR_INSTALL_STAGING = YES
+TREMOR_DEPENDENCIES = libogg
+
+# tremor has ARM assembly code that cannot be compiled in Thumb2 mode,
+# so we must force the traditional ARM mode.
+ifeq ($(BR2_arm),y)
+TREMOR_CONF_ENV = \
+       CFLAGS="$(TARGET_CFLAGS) -marm"
+endif
+
+$(eval $(autotools-package))