The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / tor / tor.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/tor/tor.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/tor/tor.mk
new file mode 100644 (file)
index 0000000..2c671ba
--- /dev/null
@@ -0,0 +1,35 @@
+################################################################################
+#
+# tor
+#
+################################################################################
+
+TOR_VERSION = 0.2.5.12
+TOR_SITE = https://dist.torproject.org
+TOR_LICENSE = BSD-3c
+TOR_LICENSE_FILES = LICENSE
+TOR_DEPENDENCIES = libevent openssl zlib
+TOR_AUTORECONF = YES
+
+TOR_CONF_OPTS = \
+       --disable-gcc-hardening \
+       --with-libevent-dir=$(STAGING_DIR)/usr \
+       --with-openssl-dir=$(STAGING_DIR)/usr \
+       --with-zlib-dir=$(STAGING_DIR)/usr
+
+ifeq ($(BR2_STATIC_LIBS),y)
+TOR_CONF_OPTS += \
+       --enable-static-libevent \
+       --enable-static-openssl \
+       --enable-static-tor \
+       --enable-static-zlib
+endif
+
+ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_i386)$(BR2_x86_64)$(BR2_PACKAGE_LIBSECCOMP),yy)
+TOR_CONF_OPTS += --enable-seccomp
+TOR_DEPENDENCIES += libseccomp
+else
+TOR_CONF_OPTS += --disable-seccomp
+endif
+
+$(eval $(autotools-package))