The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / tn5250 / tn5250.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/tn5250/tn5250.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/tn5250/tn5250.mk
new file mode 100644 (file)
index 0000000..213f02c
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# tn5250
+#
+################################################################################
+
+TN5250_VERSION = 0.17.4
+TN5250_SITE = http://downloads.sourceforge.net/project/tn5250/tn5250/$(TN5250_VERSION)
+TN5250_MAKE_OPTS = CPPFLAGS=""
+TN5250_DEPENDENCIES = ncurses
+TN5250_LICENSE = LGPLv2.1+
+TN5250_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+TN5250_CONF_OPTS += --with-ssl-dir=$(STAGING_DIR)/usr
+TN5250_DEPENDENCIES += openssl
+else
+TN5250_CONF_OPTS += --without-ssl
+endif
+
+define TN5250_INSTALL_FIXES
+       rm -f $(TARGET_DIR)/usr/bin/5250keys
+       rm -f $(TARGET_DIR)/usr/bin/xt5250
+endef
+
+TN5250_POST_INSTALL_TARGET_HOOKS += TN5250_INSTALL_FIXES
+
+$(eval $(autotools-package))