The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / tinyxml2 / 0002-Rename-test-fixed-cmake-warning.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/tinyxml2/0002-Rename-test-fixed-cmake-warning.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/tinyxml2/0002-Rename-test-fixed-cmake-warning.patch
new file mode 100644 (file)
index 0000000..409269a
--- /dev/null
@@ -0,0 +1,38 @@
+From 77631a9cf500a578338a83bc230c419bf2a05b50 Mon Sep 17 00:00:00 2001
+From: xantares <xantares09@hotmail.com>
+Date: Fri, 14 Nov 2014 19:46:18 +0100
+Subject: [PATCH] Rename test, fixed cmake warning.
+
+Signed-off-by: Romain Naour <romain.naour@openwide.fr>
+---
+ CMakeLists.txt | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4375bb9..4a8f91d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -53,10 +53,10 @@ set_target_properties(tinyxml2 PROPERTIES
+       VERSION "${GENERIC_LIB_VERSION}"\r
+       SOVERSION "${GENERIC_LIB_SOVERSION}")\r
\r
+-add_executable(test xmltest.cpp)\r
+-add_dependencies(test tinyxml2)\r
+-add_dependencies(test ${TARGET_DATA_COPY})\r
+-target_link_libraries(test tinyxml2)\r
++add_executable(xmltest xmltest.cpp)\r
++add_dependencies(xmltest tinyxml2)\r
++add_dependencies(xmltest ${TARGET_DATA_COPY})\r
++target_link_libraries(xmltest tinyxml2)\r
\r
\r
+ install(TARGETS tinyxml2\r
+@@ -76,4 +76,4 @@ endforeach()
+ configure_file(tinyxml2.pc.in tinyxml2.pc @ONLY)\r
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/tinyxml2.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)\r
\r
+-#add_test(test ${SAMPLE_NAME} COMMAND $<TARGET_FILE:${SAMPLE_NAME}>)\r
++#add_test(xmltest ${SAMPLE_NAME} COMMAND $<TARGET_FILE:${SAMPLE_NAME}>)\r
+-- 
+1.9.3
+