The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / ti-utils / ti-utils.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/ti-utils/ti-utils.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/ti-utils/ti-utils.mk
new file mode 100644 (file)
index 0000000..3141219
--- /dev/null
@@ -0,0 +1,31 @@
+################################################################################
+#
+# ti-utils
+#
+################################################################################
+
+TI_UTILS_VERSION = 06dbdb2727354b5f3ad7c723897f40051fddee49
+TI_UTILS_SITE = $(call github,gxk,ti-utils,$(TI_UTILS_VERSION))
+TI_UTILS_DEPENDENCIES = libnl host-pkgconf
+TI_UTILS_LICENSE = BSD-3c
+TI_UTILS_LICENSE_FILES = COPYING
+
+TI_UTILS_CFLAGS = $(shell $(PKG_CONFIG_HOST_BINARY) --cflags libnl-genl-3.0)
+TI_UTILS_LIBS = $(shell $(PKG_CONFIG_HOST_BINARY) --libs libnl-genl-3.0)
+
+define TI_UTILS_BUILD_CMDS
+       $(MAKE1) NFSROOT="$(STAGING_DIR)" \
+               CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) $(TI_UTILS_CFLAGS)" \
+               LIBS="$(TI_UTILS_LIBS)" -C $(@D) all
+endef
+
+define TI_UTILS_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/calibrator \
+               $(TARGET_DIR)/usr/bin/calibrator
+       $(INSTALL) -m 0755 -D $(@D)/scripts/go.sh \
+               $(TARGET_DIR)/usr/share/ti-utils/scripts/go.sh
+
+       cp -r $(@D)/ini_files $(TARGET_DIR)/usr/share/ti-utils
+endef
+
+$(eval $(generic-package))