The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / ti-gfx / 0003-km_install_modules.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/ti-gfx/0003-km_install_modules.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/ti-gfx/0003-km_install_modules.patch
new file mode 100644 (file)
index 0000000..2cf6e81
--- /dev/null
@@ -0,0 +1,19 @@
+Patch to add modules_install target to the modules makefile.  This makes
+installation a little easier.
+
+Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
+----
+Index: ti-gfx-4_09_00_01/GFX_Linux_KM/Makefile
+===================================================================
+--- ti-gfx-4_09_00_01.orig/GFX_Linux_KM/Makefile       2013-03-07 11:00:11.000000000 -0600
++++ ti-gfx-4_09_00_01/GFX_Linux_KM/Makefile    2013-05-23 01:36:29.356676281 -0500
+@@ -479,6 +479,9 @@
+ all:
+       $(MAKE) -C $(KERNELDIR) M=`pwd` $*
++install:
++      $(MAKE) -C $(KERNELDIR) M=`pwd` modules_install
++
+ clean:
+       @find . -name "*.o" -exec rm -r {} \;
+       @find . -name "*.ko" -exec rm -r {} \;