The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / tftpd / tftpd.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/tftpd/tftpd.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/tftpd/tftpd.mk
new file mode 100644 (file)
index 0000000..78df835
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# tftpd
+#
+################################################################################
+
+TFTPD_VERSION = 5.2
+TFTPD_SOURCE = tftp-hpa-$(TFTPD_VERSION).tar.xz
+TFTPD_SITE = $(BR2_KERNEL_MIRROR)/software/network/tftp/tftp-hpa
+TFTPD_CONF_OPTS = --without-tcpwrappers
+
+# Override BusyBox implementations if BusyBox is enabled.
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+TFTPD_DEPENDENCIES += busybox
+endif
+
+define TFTPD_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/tftp/tftp $(TARGET_DIR)/usr/bin/tftp
+       $(INSTALL) -D $(@D)/tftpd/tftpd $(TARGET_DIR)/usr/sbin/tftpd
+endef
+
+define TFTPD_INSTALL_INIT_SYSV
+       $(INSTALL) -D -m 0755 package/tftpd/S80tftpd-hpa $(TARGET_DIR)/etc/init.d/S80tftpd-hpa
+endef
+
+$(eval $(autotools-package))