The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / tcpdump / tcpdump.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/tcpdump/tcpdump.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/tcpdump/tcpdump.mk
new file mode 100644 (file)
index 0000000..71b844a
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# tcpdump
+#
+################################################################################
+
+TCPDUMP_VERSION = 4.7.3
+TCPDUMP_SITE = http://www.tcpdump.org/release
+TCPDUMP_LICENSE = BSD-3c
+TCPDUMP_LICENSE_FILES = LICENSE
+TCPDUMP_CONF_ENV = \
+       ac_cv_linux_vers=2 \
+       td_cv_buggygetaddrinfo=no \
+       PCAP_CONFIG=$(STAGING_DIR)/usr/bin/pcap-config
+TCPDUMP_CONF_OPTS = \
+       --without-crypto \
+       --with-system-libpcap \
+       $(if $(BR2_PACKAGE_TCPDUMP_SMB),--enable-smb,--disable-smb)
+TCPDUMP_DEPENDENCIES = zlib libpcap
+
+ifeq ($(BR2_STATIC_LIBS),y)
+TCPDUMP_CONF_OPTS += LIBS="$(shell $(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs)"
+endif
+
+# make install installs an unneeded extra copy of the tcpdump binary
+define TCPDUMP_REMOVE_DUPLICATED_BINARY
+       rm -f $(TARGET_DIR)/usr/sbin/tcpdump.$(TCPDUMP_VERSION)
+endef
+
+TCPDUMP_POST_INSTALL_TARGET_HOOKS += TCPDUMP_REMOVE_DUPLICATED_BINARY
+
+$(eval $(autotools-package))