The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / taglib / taglib.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/taglib/taglib.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/taglib/taglib.mk
new file mode 100644 (file)
index 0000000..ed08874
--- /dev/null
@@ -0,0 +1,31 @@
+################################################################################
+#
+# taglib
+#
+################################################################################
+
+TAGLIB_VERSION = 1.9.1
+TAGLIB_SITE = http://taglib.github.io/releases
+TAGLIB_INSTALL_STAGING = YES
+TAGLIB_LICENSE = LGPLv2.1 MPL
+TAGLIB_LICENSE_FILES = COPYING.LGPL COPYING.MPL
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+TAGLIB_DEPENDENCIES += zlib
+endif
+
+ifeq ($(BR2_PACKAGE_TAGLIB_ASF),y)
+TAGLIB_CONF_OPTS += -DWITH_ASF=ON
+endif
+
+ifeq ($(BR2_PACKAGE_TAGLIB_MP4),y)
+TAGLIB_CONF_OPTS += -DWITH_MP4=ON
+endif
+
+define TAGLIB_REMOVE_DEVFILE
+       rm -f $(TARGET_DIR)/usr/bin/taglib-config
+endef
+
+TAGLIB_POST_INSTALL_TARGET_HOOKS += TAGLIB_REMOVE_DEVFILE
+
+$(eval $(cmake-package))