The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / sysdig / 0001-remove-dkms-module-updater.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/sysdig/0001-remove-dkms-module-updater.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/sysdig/0001-remove-dkms-module-updater.patch
new file mode 100644 (file)
index 0000000..8d5c99d
--- /dev/null
@@ -0,0 +1,31 @@
+Remove DKMS module updater
+
+This patch disables the in target installation of DKMS module updater
+mechanism unneeded in buildroot.
+
+Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
+
+--- a/driver/CMakeLists.txt
++++ b/driver/CMakeLists.txt
+@@ -39,21 +39,3 @@ add_custom_target(install_driver
+       WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+       VERBATIM)
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/Makefile.dkms
+-      RENAME Makefile
+-      DESTINATION "src/sysdig-${SYSDIG_VERSION}")
+-
+-install(FILES
+-      ${CMAKE_CURRENT_BINARY_DIR}/dkms.conf
+-      dynamic_params_table.c
+-      event_table.c
+-      flags_table.c
+-      main.c
+-      ppm.h
+-      ppm_events.c
+-      ppm_events.h
+-      ppm_events_public.h
+-      ppm_fillers.c
+-      ppm_ringbuffer.h
+-      syscall_table.c
+-      DESTINATION "src/sysdig-${SYSDIG_VERSION}")