The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / sunxi-tools / sunxi-tools.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/sunxi-tools/sunxi-tools.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/sunxi-tools/sunxi-tools.mk
new file mode 100644 (file)
index 0000000..2dfd496
--- /dev/null
@@ -0,0 +1,37 @@
+################################################################################
+#
+# sunxi-tools
+#
+################################################################################
+
+SUNXI_TOOLS_VERSION = v1.2
+SUNXI_TOOLS_SITE = $(call github,linux-sunxi,sunxi-tools,$(SUNXI_TOOLS_VERSION))
+SUNXI_TOOLS_LICENSE = GPLv2+
+SUNXI_TOOLS_LICENSE_FILES = COPYING
+HOST_SUNXI_TOOLS_DEPENDENCIES = host-libusb
+FEX2BIN = $(HOST_DIR)/usr/bin/fex2bin
+
+define HOST_SUNXI_TOOLS_BUILD_CMDS
+       $(HOST_MAKE_ENV) $(MAKE) $(HOST_CONFIGURE_OPTS) \
+               CFLAGS="$(HOST_CFLAGS) -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" \
+               -C $(@D)
+endef
+
+define HOST_SUNXI_TOOLS_INSTALL_CMDS
+       for i in fexc bin2fex fex2bin bootinfo fel pio; do \
+               $(INSTALL) -D -m 0755 $(@D)/$$i $(HOST_DIR)/usr/bin/$$i ; \
+       done
+endef
+
+define SUNXI_TOOLS_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" \
+               -C $(@D) nand-part
+endef
+
+define SUNXI_TOOLS_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/nand-part $(TARGET_DIR)/usr/bin/nand-part
+endef
+
+$(eval $(generic-package))
+$(eval $(host-generic-package))