The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / subversion / subversion.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/subversion/subversion.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/subversion/subversion.mk
new file mode 100644 (file)
index 0000000..3c6c3f0
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# subversion
+#
+################################################################################
+
+SUBVERSION_VERSION = 1.7.19
+SUBVERSION_SITE = http://archive.apache.org/dist/subversion
+SUBVERSION_LICENSE = Apache-2.0
+SUBVERSION_LICENSE_FILES = LICENSE
+SUBVERSION_DEPENDENCIES = host-pkgconf apr apr-util expat neon zlib sqlite
+SUBVERSION_CONF_OPTS = \
+       --with-expat=$(STAGING_DIR)/usr/include:$(STAGING_DIR)/usr/lib: \
+       --with-apr=$(STAGING_DIR)/usr \
+       --with-apr-util=$(STAGING_DIR)/usr \
+       --with-zlib=$(STAGING_DIR)/usr \
+       --with-neon=$(STAGING_DIR)/usr \
+       --without-gssapi \
+       --without-serf \
+       --without-apxs \
+       --without-berkeyley-db \
+       --without-sasl \
+       --without-gnome-keyring \
+       --without-ssl \
+       --without-libmagic
+
+$(eval $(autotools-package))