The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / stress / stress.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/stress/stress.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/stress/stress.mk
new file mode 100644 (file)
index 0000000..4bb801e
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# stress
+#
+################################################################################
+
+STRESS_VERSION = 1.0.4
+STRESS_SITE = http://people.seas.harvard.edu/~apw/stress
+STRESS_LICENSE = GPLv2+
+STRESS_LICENSE_FILES = COPYING
+STRESS_AUTORECONF = YES
+
+# Stress is linked statically if the --enable-static is specified.
+# However, this option is always specified in the global
+# SHARED_STATIC_LIBS_OPTS to tell packages to build static libraries,
+# if supported.
+#
+# If the BR2_STATIC_LIBS is not defined, we have to specify
+# --disable-static explicitly to get stress linked dynamically.
+#
+# Also, disable documentation by undefining makeinfo
+STRESS_CONF_OPTS = \
+       $(if $(BR2_STATIC_LIBS),,--disable-static) \
+       MAKEINFO=:
+
+$(eval $(autotools-package))