The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / sstrip / sstrip.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/sstrip/sstrip.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/sstrip/sstrip.mk
new file mode 100644 (file)
index 0000000..fe57b3c
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# sstrip
+#
+################################################################################
+
+SSTRIP_SITE = svn://svn.openwrt.org/openwrt/trunk/tools/sstrip
+SSTRIP_VERSION = 20154
+HOST_SSTRIP_BINARY = $(GNU_TARGET_NAME)-sstrip
+
+define SSTRIP_BUILD_CMDS
+       cd $(@D) ; \
+       $(TARGET_CC) $(TARGET_CFLAGS) -include endian.h -include byteswap.h \
+               -o sstrip src/sstrip.c
+endef
+
+define SSTRIP_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/sstrip $(TARGET_DIR)/usr/bin/sstrip
+endef
+
+define HOST_SSTRIP_BUILD_CMDS
+       cd $(@D) ; \
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -include byteswap.h \
+               -o sstrip src/sstrip.c
+endef
+
+define HOST_SSTRIP_INSTALL_CMDS
+       $(INSTALL) -D $(@D)/sstrip $(HOST_DIR)/usr/bin/$(HOST_SSTRIP_BINARY)
+endef
+
+$(eval $(generic-package))
+$(eval $(host-generic-package))