The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / snmppp / snmppp.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/snmppp/snmppp.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/snmppp/snmppp.mk
new file mode 100644 (file)
index 0000000..147af60
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# snmppp
+#
+################################################################################
+
+SNMPPP_VERSION = 3.3.4
+SNMPPP_SOURCE = snmp++-$(SNMPPP_VERSION).tar.gz
+SNMPPP_SITE = http://www.agentpp.com/download
+SNMPPP_DEPENDENCIES = host-pkgconf
+SNMPPP_INSTALL_STAGING = YES
+# no configure script in tarball
+SNMPPP_AUTORECONF = YES
+SNMPPP_CONF_OPTS = $(if $(BR2_PACKAGE_SNMPPP_LOGGING),--enable-logging,--disable-logging)
+SNMPPP_LICENSE = SNMP++
+SNMPPP_LICENSE_FILES = src/v3.cpp
+
+ifeq ($(BR2_PACKAGE_SNMPPP_SNMPV3),y)
+SNMPPP_CONF_OPTS += --enable-snmpv3
+SNMPPP_DEPENDENCIES += openssl
+else
+SNMPPP_CONF_OPTS += --disable-snmpv3
+endif
+
+$(eval $(autotools-package))