The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / sl / sl.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/sl/sl.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/sl/sl.mk
new file mode 100644 (file)
index 0000000..bb28b2a
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# sl
+#
+################################################################################
+
+SL_VERSION = 5.02
+SL_SITE = $(call github,mtoyoda,sl,$(SL_VERSION))
+SL_LICENSE = Custom
+SL_LICENSE_FILES = LICENSE
+SL_DEPENDENCIES = ncurses
+
+define SL_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define SL_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/sl $(TARGET_DIR)/usr/bin/sl
+endef
+
+$(eval $(generic-package))