The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / sigrok-cli / sigrok-cli.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/sigrok-cli/sigrok-cli.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/sigrok-cli/sigrok-cli.mk
new file mode 100644 (file)
index 0000000..34e0a0e
--- /dev/null
@@ -0,0 +1,29 @@
+################################################################################
+#
+# sigrok-cli
+#
+################################################################################
+
+SIGROK_CLI_VERSION = c59bf72b694ab1d08b2ea44de4349c277e206414
+# No https access on upstream git
+SIGROK_CLI_SITE = git://sigrok.org/sigrok-cli
+SIGROK_CLI_LICENSE = GPLv3+
+SIGROK_CLI_LICENSE_FILES = COPYING
+# Git checkout has no configure script
+SIGROK_CLI_AUTORECONF = YES
+SIGROK_CLI_DEPENDENCIES = host-pkgconf libsigrok
+
+ifeq ($(BR2_PACKAGE_LIBSIGROKDECODE),y)
+SIGROK_CLI_CONF_OPTS += --with-libsigrokdecode
+SIGROK_CLI_DEPENDENCIES += libsigrokdecode
+else
+SIGROK_CLI_CONF_OPTS += --with-libsigrokdecode=NO
+endif
+
+define SIGROK_CLI_ADD_MISSING
+       mkdir -p $(@D)/autostuff
+endef
+
+SIGROK_CLI_PRE_CONFIGURE_HOOKS += SIGROK_CLI_ADD_MISSING
+
+$(eval $(autotools-package))