The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / shairport-sync / shairport-sync.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/shairport-sync/shairport-sync.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/shairport-sync/shairport-sync.mk
new file mode 100644 (file)
index 0000000..bfcdb35
--- /dev/null
@@ -0,0 +1,55 @@
+################################################################################
+#
+# shairport-sync
+#
+################################################################################
+
+SHAIRPORT_SYNC_VERSION = 2.2.3
+SHAIRPORT_SYNC_SITE = $(call github,mikebrady,shairport-sync,$(SHAIRPORT_SYNC_VERSION))
+
+SHAIRPORT_SYNC_LICENSE = MIT, BSD-3c
+SHAIRPORT_SYNC_LICENSE_FILES = LICENSES
+SHAIRPORT_SYNC_DEPENDENCIES = alsa-lib libdaemon popt host-pkgconf
+
+# Touching configure.ac with the patches
+SHAIRPORT_SYNC_AUTORECONF = YES
+
+SHAIRPORT_SYNC_CONF_OPTS = --with-alsa
+
+# Avahi or tinysvcmdns (shaiport-sync bundles its own version of tinysvcmdns).
+# Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
+# and dbus is selected. Since there is no BR2_PACKAGE_LIBAVAHI_CLIENT config
+# option yet, use the avahi-daemon and dbus congig symbols to check for
+# libavahi-client.
+ifeq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yy)
+SHAIRPORT_SYNC_DEPENDENCIES += avahi
+SHAIRPORT_SYNC_CONF_OPTS += --with-avahi
+else
+SHAIRPORT_SYNC_CONF_OPTS += --with-tinysvcmdns
+endif
+
+# OpenSSL or PolarSSL
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+SHAIRPORT_SYNC_DEPENDENCIES += openssl
+SHAIRPORT_SYNC_CONF_OPTS += --with-ssl=openssl
+else
+SHAIRPORT_SYNC_DEPENDENCIES += polarssl
+SHAIRPORT_SYNC_CONF_OPTS += --with-ssl=polarssl
+endif
+
+ifeq ($(BR2_PACKAGE_SHAIRPORT_SYNC_LIBSOXR),y)
+SHAIRPORT_SYNC_DEPENDENCIES += libsoxr
+SHAIRPORT_SYNC_CONF_OPTS += --with-soxr
+endif
+
+define SHAIRPORT_SYNC_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/shairport-sync \
+               $(TARGET_DIR)/usr/bin/shairport-sync
+endef
+
+define SHAIRPORT_SYNC_INSTALL_INIT_SYSV
+       $(INSTALL) -D -m 0755 package/shairport-sync/S99shairport-sync \
+               $(TARGET_DIR)/etc/init.d/S99shairport-sync
+endef
+
+$(eval $(autotools-package))