The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / sed / sed.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/sed/sed.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/sed/sed.mk
new file mode 100644 (file)
index 0000000..b819300
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# sed
+#
+################################################################################
+
+SED_VERSION = 4.2.2
+SED_SITE = $(BR2_GNU_MIRROR)/sed
+SED_LICENSE = GPLv3
+SED_LICENSE_FILES = COPYING
+
+SED_CONF_OPTS = \
+       --bindir=/usr/bin \
+       --libdir=/lib \
+       --libexecdir=/usr/lib \
+       --sysconfdir=/etc \
+       --datadir=/usr/share \
+       --mandir=/usr/share/man \
+       --infodir=/usr/share/info \
+       --include=$(STAGING_DIR)/usr/include
+
+define SED_MOVE_BINARY
+       mv $(TARGET_DIR)/usr/bin/sed $(TARGET_DIR)/bin/
+endef
+
+SED_POST_INSTALL_TARGET_HOOKS = SED_MOVE_BINARY
+
+$(eval $(autotools-package))