The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / sdl_mixer / sdl_mixer.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/sdl_mixer/sdl_mixer.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/sdl_mixer/sdl_mixer.mk
new file mode 100644 (file)
index 0000000..a602b6e
--- /dev/null
@@ -0,0 +1,37 @@
+################################################################################
+#
+# sdl_mixer
+#
+################################################################################
+
+SDL_MIXER_VERSION = 1.2.12
+SDL_MIXER_SOURCE = SDL_mixer-$(SDL_MIXER_VERSION).tar.gz
+SDL_MIXER_SITE = http://www.libsdl.org/projects/SDL_mixer/release
+SDL_MIXER_LICENSE = zlib
+SDL_MIXER_LICENSE_FILES = COPYING
+
+SDL_MIXER_INSTALL_STAGING = YES
+SDL_MIXER_DEPENDENCIES = sdl
+SDL_MIXER_CONF_OPTS = \
+       --without-x \
+       --with-sdl-prefix=$(STAGING_DIR)/usr \
+       --disable-music-midi \
+       --disable-music-mod \
+       --disable-music-mp3 \
+       --disable-music-flac # configure script fails when cross compiling
+
+ifeq ($(BR2_PACKAGE_LIBMAD),y)
+SDL_MIXER_CONF_OPTS += --enable-music-mp3-mad-gpl
+SDL_MIXER_DEPENDENCIES += libmad
+else
+SDL_MIXER_CONF_OPTS += --disable-music-mp3-mad-gpl
+endif
+
+ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
+SDL_MIXER_CONF_OPTS += --enable-music-ogg
+SDL_MIXER_DEPENDENCIES += libvorbis
+else
+SDL_MIXER_CONF_OPTS += --disable-music-ogg
+endif
+
+$(eval $(autotools-package))