The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / screen / screen.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/screen/screen.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/screen/screen.mk
new file mode 100644 (file)
index 0000000..827e776
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# screen
+#
+################################################################################
+
+SCREEN_VERSION = 4.2.1
+SCREEN_SITE = $(BR2_GNU_MIRROR)/screen
+SCREEN_LICENSE = GPLv3+
+SCREEN_LICENSE_FILES = COPYING
+SCREEN_DEPENDENCIES = ncurses
+SCREEN_AUTORECONF = YES
+SCREEN_CONF_ENV = CFLAGS="$(TARGET_CFLAGS)"
+SCREEN_MAKE = $(MAKE1)
+SCREEN_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) SCREEN=screen install_bin
+
+define SCREEN_INSTALL_SCREENRC
+       $(INSTALL) -m 0755 -D $(@D)/etc/screenrc $(TARGET_DIR)/etc/screenrc
+endef
+
+SCREEN_POST_INSTALL_TARGET_HOOKS += SCREEN_INSTALL_SCREENRC
+
+$(eval $(autotools-package))