The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / screen / 0007-install-always-chmod.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/screen/0007-install-always-chmod.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/screen/0007-install-always-chmod.patch
new file mode 100644 (file)
index 0000000..0aa7690
--- /dev/null
@@ -0,0 +1,29 @@
+From: Maarten ter Huurne <maarten@treewalker.org>
+Date: Mon, 15 Sep 2014 00:03:05 +0200
+Subject: Change binary permission flags even if chown fails
+
+Typically when creating a package, the build is not run as root, so
+the chown will fail. But the chmod can still be done.
+
+Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
+---
+ Makefile.in | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 65549e9..3c12fdb 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -84,7 +84,8 @@ screen: $(OFILES)
+ install_bin: .version screen
+       $(INSTALL_PROGRAM) screen $(DESTDIR)$(bindir)/$(SCREEN)
+-      -chown root $(DESTDIR)$(bindir)/$(SCREEN) && chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
++      -chown root $(DESTDIR)$(bindir)/$(SCREEN)
++      -chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
+ # This doesn't work if $(bindir)/screen is a symlink
+       rm -f $(DESTDIR)$(bindir)/screen
+       (cd $(DESTDIR)$(bindir) && ln -f -s $(SCREEN) screen)
+-- 
+1.8.4.5
+